Error when runing deep learning yolov3 model

542
4
Jump to solution
08-23-2021 08:23 PM
lienpham83
New Contributor III

Hi all,

I am running the arcgis.learn model as below:

yolov3=arcgis.learn.YOLOv3(data)
yolov3.lr_find()
yolov3.fit(20,lr=None,one_cycle=True,checkpoint=False)

However, it has an error: ValueError: 'vertices' must be 2D with shape (M, 2). Your input has shape (0,).
<Figure size 576x576 with 4 Axes>

How can I fix this error?community.PNG

Thank you so much for your help.

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
lienpham83
New Contributor III

Hi Sandeep,

I have fixed the error. I found out that my training samples polygon has the fields class, classValue, Confidence. When I deleted the field class and confidence, everything is normal.

Cheers,

Lien

View solution in original post

0 Kudos
4 Replies
DanPatterson
MVP Esteemed Contributor

how did you prepare your "data" ?

arcgis.learn module — arcgis 1.9 documentation


... sort of retired...
0 Kudos
lienpham83
New Contributor III

Hi Dan,

To get the data, I have two raster files and then I merge them into 1 raster file. I got the samples with different bounding box sizes and then run 

data=prepare_data(training_deep, chip_size=448, batch_size=4, transforms=None)

Then, the details error was shown in my edited post.

 

 

 

0 Kudos
SandeepKumar1
Esri Contributor

Hi,

Can you paste the full error ?

Thanks,

Sandeep

0 Kudos
lienpham83
New Contributor III

Hi Sandeep,

I have fixed the error. I found out that my training samples polygon has the fields class, classValue, Confidence. When I deleted the field class and confidence, everything is normal.

Cheers,

Lien

0 Kudos