Problem with Legend markers in print result using non A4 Portrait layout(v4)

203
3
09-01-2019 06:03 AM
Highlighted
New Contributor III

1. Customized Print Task (non widget)

2. The markers in the print result's legend (by layout) - see attached image

    a. A4-Portrait pdf/png/jpg - OK (right part)

    b. Any other layout - blurry markers in the legend (left part)

We are using arcgis js-api, v4.12, it didn't work in previous versions as well.

Reply
0 Kudos
3 Replies
Highlighted
Esri Regular Contributor

Hi Netta,

Are those picture marker symbols? What sort of renderer and symbology are you using for those features in the code?

What is the ArcGIS Server version of the Print Service that you are using? Is it a custom Print Service?

When you look at the network traffic, are there any differences between the request with different layouts (e.g. blurry vs. non-blurry)?

Reply
0 Kudos
Highlighted
New Contributor III

Hi - thanks & sorry for the delay

1. Picture marker symbols - legend link: https://gisn.tel-aviv.gov.il/arcgis/rest/services/WM/IView2WM/MapServer/legend 

2. ArcGIS server 10.61

3. Link to the GP server: https://gisn.tel-aviv.gov.il/arcgis/rest/services/WM/ExportWebMapIViewWM/GPServer 

4. We are working a lot on converting our system in js API 4,

I've been working on rewriting our printing section for a while (v 4.5-4.12), 

the markers appear OK in the printed map body and poorly in the legend (except A4 P).

 

Thanks again,

Netta

Reply
0 Kudos
Highlighted
Esri Regular Contributor

It looks like the Print Service you are using was published from ArcMap. Is there a way you could publish a similar Print Service from ArcGIS Pro and test with that? You could also try with the AGO print task and the 4x Print widget (includes Legend) and your data.

AGO print task

Task: Export Web Map Task 

I tried that with a simple test app, and the Legend items look fine with PictureMarkerSymbols:

https://codepen.io/noash/pen/wvwbBVj 

Reply
0 Kudos