ESRI JS API 4.X Migration and WebGL Concerns

795
1
03-22-2019 07:41 AM
VietLe
by
New Contributor

Hi,

This is a question about potentially migrating our enterprise's ESRI Javascript API from 3.27 to 4.10. As part of our proof of concept, we've been experimenting with different browsers and hardware to measure performance. We noted 4.x consistently crashes in IE11, however this was expected based on the documentation of IE11 not being optimized for WebGL, and our applications being very data intensive. However, we still notice a performance slowdown even on chrome and safari. Even displaying a simple basemap, either in our own proofs of concept or in your online examples, takes noticeably longer compared to our data intensive applications in 3.x, which are currently quite smooth. It seems to vary by hardware. We wanted to ask what performance concerns we might expect if we migrate to 4.x and WebGL, if the performance varies hardware to hardware, and what are the GPU limits and recommendations. If we make a transition, we want to make sure our enterprise and users' hardware can support it.

Also, up to at least 4.9 we see we can still configure the api to use svgs for layer rendering. Can you provide us with the configuration sample code to do so using the npm esri-loader? And will this capability still be available moving forward, or has it been completely deprecated as indicated in the release notes for 4.10?

Thanks for your time and insight,

Viet

1 Reply
AndyGup
Esri Regular Contributor

Hi Viet, thanks for bringing this to our attention. Yes, since version 4.10 the API is WebGL only. Can you open a tech support ticket? That's the best and most efficient approach for capturing the information needed and figuring out what's going on. When you have a ticket number email me: agup at esri dot com and I'll track it. We have lots of questions about your environment, the tests you ran, the applications you used, as well as details about your data, services and hardware. 

0 Kudos