why do my popups work in version 4.4 but fail in 4.5?

220
3
Jump to solution
10-25-2017 08:20 AM
DouglasGreenfield
New Contributor III

I have attached my code. I have a complex popup involving many data layers. When I change the version to 4.5 and open it the first popup works as expected but then does not go away and you can get info for any other property. In 4.4 every property gets a new popup as designed. Is this a bug? A change in the design?

0 Kudos
1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

Douglas,

  Because you are using the identifyTask and populating the popups content, you do not specify the features property. You use the features property when using a popuptemplate for a layer or graphic. I also did some css changes to get rid of the scrollbars for you.

View solution in original post

3 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Douglas,

  Because you are using the identifyTask and populating the popups content, you do not specify the features property. You use the features property when using a popuptemplate for a layer or graphic. I also did some css changes to get rid of the scrollbars for you.

View solution in original post

DouglasGreenfield
New Contributor III

Thanks so much! The css cleanup was great too as I'm kind of weak on that stuff.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Glad to hear it help.

Don't forget to mark this question as answered by clicking on the "Mark Correct" link on the reply that answered your question.

0 Kudos