What JS version for Arcgis server?

318
2
12-17-2019 12:35 AM
LarsFagerbakke
New Contributor III

Hi, 

The client is running server version 10.6, and I'm having some problem creating a JavaScript application.

What version of the library is supported by 10.6?

If I try to create a Feature Layer I get "request:server": "Cannot read property 'replace' of undefined" in my console

Tags (1)
0 Kudos
2 Replies
George_Thompson
Esri Frequent Contributor

Adding more groups, you current have this in the GeoNet help section. You may want to move it to one of the following:

ArcGIS EnterpriseEnterprise GISDeveloper Communities

--- George T.
0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Lars,

   10.6 will support all JS API versions available. The error you are seeing is because the object you are trying to use the replace method on is null, not because of a API version issue.