WFS Arcgis API for Javascript 4.*

1525
9
07-05-2018 01:06 PM
MinutellaDaniele
New Contributor

How I work with WFS layers with Arcgis API for javascript 4.*?

I view this link but it is for arcgis api for javascript 3.*

WFS Layer | ArcGIS API for JavaScript 3.25 

Thanks.

0 Kudos
9 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

If you check the compatibility matrix WFS is still marked as coming soon.

MinutellaDaniele
New Contributor

Thanks for response. How can I solve this problem without waiting for a new version to be released? Is there a workaround? 

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

There is no workaround that I am aware of.

0 Kudos
julienrobitaille
New Contributor III

Two years later from the original post, I have the same question. Is there a way to use WFS in the Javascript API ? 

Thank you!

marcoyfkwok
New Contributor

Two and a half years later from the original post, I have the same question. Is there a way to use WFS in the Javascript API 4.x?

Thank you!

AdministrationOGSL
New Contributor

Hello, 
They do not support WFS, but they support the new feature service of the OGC standards, OGC API Features

 https://developers.arcgis.com/javascript/latest/api-reference/esri-layers-OGCFeatureLayer.html

It basically works the same way as WFS.

Hope this helps!

LukasWürsch
New Contributor III

Hi, so is it possible to load regular WFS services with the OGCFeatureLayer class? 

What I am trying to do is load a WFS such as this one with API 4. I did not manage to set the parameters right to make it work.

I did not find a working example with a generic WFS service, but a post with the same issue. 

0 Kudos
julienrobitaille
New Contributor III

Hi! 
I actually replied by accident with my organisation account (AdministrationOGSL), but I am actually the same person. So the issue you shared was actually posted by me. 
The thing is that the OGCFeatureLayer class of ArcGIS uses the OGC API - Features, and not WFS. 
The OGC API - Features is a service to access features, but that is newer than WFS.
So to use it, this service (OGC API-Features) has to be added to the capabilities of the geoserver that you use. If it is the geoserver of your organisation, this can be easily done (https://docs.geoserver.org/latest/en/user/community/ogc-api/index.html ). If not, I think your best bet would be tu use another module to create your map (such as OpenLayers).
Hope this helps! 

LukasWürsch
New Contributor III

Thanks for the clarification. Unfortunately changing capabilities is not possible as the server is not mine. We'll have to wait until WMS is implemented in API 4 then

0 Kudos