Unable to view watchUtil inside @arcgis/core

537
3
02-23-2021 10:52 PM
phanivvk
New Contributor

Hi There,

In context to my previous post, 

https://community.esri.com/t5/arcgis-api-for-javascript/draw-circle-on-mapview/m-p/1027727#M71800

I'm unable to locate wathUtil under package "@arcgis/core/..."

Let me if Im missing any packages or imports

 

0 Kudos
3 Replies
BlakeTerhune
MVP Regular Contributor

Please post your require statement parameters and function declaration. It should look like this (with your other requires listed as well).

require(["esri/core/watchUtils"], function(watchUtils) {
  /* code goes here */
});

 

0 Kudos
ReneRubalcava
Frequent Contributor II
import * as watchUtils from "@arcgis/core/core/watchUtils";

 

I just made a video on watchUtils a couple of days ago.

phanivvk
New Contributor

I'm getting undefined error for pausable

watchUtils.pausable(layerView,"updating",(val:any)=>{

                console.log("**** WATCH UTIL PAUSABLE *****",val);

            });              
            
0 Kudos