SketchViewModel.activeLineSymbol

205
2
Jump to solution
07-14-2021 01:14 PM
EthanBodin1
New Contributor III

The API documentation for SketchViewModel in v4.20 includes an activeFillSymbol property though it does not include the activeLineSymbol property that is present on SketchViewModel objects in the debugger. Is activeLineSymbol not intended to be used?

0 Kudos
1 Solution

Accepted Solutions
JoseBanuelos
Esri Contributor

Hello @EthanBodin1 

We purposely did not publicly document the activeLineSymbol property. There was demand to document the activeFillSymbol but not for the activeLineSymbol. I believe, as you may feel as well, it would make more sense to publicly document this. We will strongly consider this for next release. There were some concerns initially on exposing this, but we will be looking into this again. Appreciate your feedback. You can use the activeLineSymbol in the meantime, there is just no documentation on this at the moment.

Thanks,

Jose

View solution in original post

0 Kudos
2 Replies
JoseBanuelos
Esri Contributor

Hello @EthanBodin1 

We purposely did not publicly document the activeLineSymbol property. There was demand to document the activeFillSymbol but not for the activeLineSymbol. I believe, as you may feel as well, it would make more sense to publicly document this. We will strongly consider this for next release. There were some concerns initially on exposing this, but we will be looking into this again. Appreciate your feedback. You can use the activeLineSymbol in the meantime, there is just no documentation on this at the moment.

Thanks,

Jose

0 Kudos
EthanBodin1
New Contributor III

Thank you for the response @JoseBanuelos. I will use activeLineSymbol and hope to see it documented in a future release.