Print Widget 300 DPI

451
7
02-04-2020 04:29 AM
SrinivasaRao1
New Contributor III

We have been trying to resolve the issue on Custom Print Widget which we have developed for some of the templates but we are encountering issue for one template 22 X 34 size for 300 DPI where tool thrown error saying that "Timeout exceeded". Could any one help us in understanding this issue and solution to fix the error.

Tags (1)
0 Kudos
7 Replies
ShaneMiles
Esri Contributor

Hi Udaya Rao‌, 

Could it be what you have the esriConfig.defaults.io.timeout set to? The default is I believe is 60 seconds before returning an error. I hope this helps answer your question. 

Shane

Noah-Sager
Esri Regular Contributor

What print service are you using? Is it the Esri hosted utility print service on ArcGIS Online, or is this a print service you published to your own instance of Server?

0 Kudos
SrinivasaRao1
New Contributor III

Published to our own instance of server

0 Kudos
Noah-Sager
Esri Regular Contributor

Is this using Web AppBuilder or Experience Builder, or a custom JS API app? I wonder if there is some issue with the size of the print request being too large for the server to handle, so it times out. Couple things to try: 1) reduce the DPI and see if the request passes, 2) try re-publishing the custom print service (did you use ArcMap or ArcGIS Pro for this?).

0 Kudos
SrinivasaRao1
New Contributor III

Thanks for comments.

Using Web AppBuilder

Yes size may be large 22X34 only for this size we have seen issue with more than 300 DPI and less than 300 DPI is working fine

Publishing was done through ArcGIS Map GP service

Tried to republish the service many times but it was same issue

is there any other alternative solution to handle.

0 Kudos
Noah-Sager
Esri Regular Contributor

I would try republishing the print service with ArcGIS Pro, or reduce the DPI. Reducing the DPI by 50 to 100 shouldn't reduce the quality too much, but will definitely help with the size of the request.

0 Kudos
SrinivasaRao1
New Contributor III

Its a client request, as I told it is working in less than 300 DPI and client requires on 300 DPI only. Please let us know if there is any solution on this.

0 Kudos