MapView initialization error

205
1
10-24-2019 06:54 AM
RomanKönig
New Contributor III

We are having issues with a single customer machine (until now) when initializing a MapView.

The constructor new MapView() throws an error displaying "WebGL not supported.

Now we asked the customer to run https://webglreport.com

https://webglreport.com/?v=1 displays green whereas 

https://webglreport.com/?v=2 displays not supported

The customer machine has a Nvidia Quadro NVS 440 graphic card and we asked them to install the newest available drivers installed, but this card does not meet the requirements stated at https://developers.arcgis.com/javascript/latest/guide/system-requirements/index.html 

My question is - is there any possibility to check if the system/graphic card is sufficient prior to initializing and running into errors on initializing or using API objects - something like a Javascript API runSupportTest() method or anything like that?

0 Kudos
1 Reply
RomanKönig
New Contributor III

The mentioned application uses the 4.11 API

In a newer application (v 4.13) i found "esri/views/support/WebGLRequirements" performing a check and displaying a different message on another machine.

Is this a new check performed since 4.12 or 4.13 ?

0 Kudos