libtess.js error in 4.22

1042
9
01-11-2022 03:27 PM
JayHill
Occasional Contributor II

I am getting the following error in the console, on an app I am updating.

Got error 100151 libtess.js:13

Got error 100152 libtess.js:13

It happens when I pan or zoom after clicking on a polygon to pull up a popup. A few times it seems to enter an infinite loop of these errors and I have to close the tab and reload the app. 

 

Any help would be appreciated.

0 Kudos
9 Replies
ReneRubalcava
Frequent Contributor II

Can't tell by the error. If you have a sample application, could take a look.

0 Kudos
JayHill
Occasional Contributor II

Thanks Rene

Here is a link to the app.  

It may take some panning and playing around with the Wetland Conditions Layer on to get the error.

0 Kudos
UndralBatsukh
Esri Regular Contributor

Hi there, 

I am able to reproduce the issue using Wetland Conditions Layer. We created an issue for this. I will update you once we have a fix for this issue. Hopefully, wetland conditions map service will be around for a while for us to test the issue. 

Thanks,

-Undral

0 Kudos
JayHill
Occasional Contributor II

Undral

 

It will be for sure. Is this a bug in the api or the layer?

 

Jay

0 Kudos
UndralBatsukh
Esri Regular Contributor

Issue in the API. But your service will help to debug the issue. 

 

Thanks

0 Kudos
JayHill
Occasional Contributor II

We have a scheduled upgrade for arcgis server 10.8.1 to 10.9.1 this thursday @UndralBatsukh will this affect your testing?

0 Kudos
UndralBatsukh
Esri Regular Contributor

Hi there, 

Please update the server. That might fix the issue. Please let me know what you see after the upgrade.

0 Kudos
JayHill
Occasional Contributor II

Undral

 

It did not fix the issue.

 

0 Kudos
UndralBatsukh
Esri Regular Contributor

Hi @JayHill 

We fixed this issue at 4.24 and it will be released end of June. In meantime, you can test the fix on our next version: https://codepen.io/U_B_U/pen/dyVQwXy?editors=1000

0 Kudos