Layer List expand arrow not showing in v3.16 and IE 11 latest update

2436
8
03-16-2016 10:09 AM
SimonFisher
Occasional Contributor II

After the latest IE 11 update the Layer List Widget expand arrow is no longer showing up.  This only seems to be the case for API v3.16 and the latest IE 11 build 11.0.9600.18231 (Update versions 11.0.29).  I believe this is the update that broke it https://support.microsoft.com/en-us/kb/3139929#bookmark-nonsecurityfix

This issue can be seen on the sample page with the correct IE 11 version

http://developers.arcgis.com/javascript/samples/widget_layerlist_basic/

There is no issue in earlier versions of IE or any versions of Chrome that I can see.  Also, if I revert back to API v3.15 the issue seems to disappear.

Tags (1)
0 Kudos
8 Replies
KenBuja
MVP Honored Contributor

I'm running IE at 11.0.9600.18320 with update version 11.0.29 and it is working.

layerlist_ie.png

SimonFisher
Occasional Contributor II

Wow, one minor point release difference.  Here is a screenshot at 11.0.9600.18231 (Update versions 11.0.29), not working.

Ken, What OS are you on?  I'm on Windows 8.1.

0 Kudos
KenBuja
MVP Honored Contributor

I'm on Windows 7. I tested this on a Windows 10 machine and replicated your error.

layerlist_ie.jpg

SimonFisher
Occasional Contributor II

Thanks, at least I know its not something specific to my machine.

0 Kudos
SimonFisher
Occasional Contributor II

Could someone at ESRI take a look at this to see if it's a bug in the ArcGIS JavaScript API or a bug in IE 11 (Update versions 11.0.29) on Windows 8/10 ?

0 Kudos
KenBuja
MVP Honored Contributor

You should contact Esri and submit a bug report about this.

0 Kudos
SimonFisher
Occasional Contributor II

In case anyone else is interested a bug has been submitted to ESRI support.

SimonFisher
Occasional Contributor II

This issue appears to be fixed now.

0 Kudos