Javascript API 3.31 drawing circle artifact created in Chrome

858
9
03-02-2020 11:36 PM
FC_Basson
MVP Regular Contributor

What is the issue/bug with drawing toolbar of the the 3.31 API?  When drawing a circle, triangle or ellipse with the drawing toolbar, an extra artifact shape is created inside the new drawing shape.  Even the live example (Shapes and Symbols) and the Sandbox example (ArcGIS API for JavaScript Sandbox) shows this behaviour.  This does not happen in version 3.30.

9 Replies
FC_Basson
MVP Regular Contributor

Just checked and it seems that the issue is limited to Chrome.  Works in Firefox and Edge.

0 Kudos
KenBuja
MVP Honored Contributor

I'm not seeing that in Chrome 80.0.3987.116

0 Kudos
FC_Basson
MVP Regular Contributor

That's weird! I think one of the Esri developers fixed it secretly.   It was definitely creating a funny artifact, but now it is fine and I can't replicate the issue of earlier.  I'm using Chrome 80.0.3987.122.

0 Kudos
KenBuja
MVP Honored Contributor

And I'm up to 80.0.3987.122 also and not seeing it.

0 Kudos
FC_Basson
MVP Regular Contributor

The issue showed up again.  This is what it looks like in the sandbox example.

Chrome 80.0.3987.132

0 Kudos
KenBuja
MVP Honored Contributor

I'm still not seeing it in either the live page or the sandbox. I'm also at 132 now

RobertScheitlin__GISP
MVP Esteemed Contributor

I have to report the same as Ken. I do not see any artifact when using the sample in the sandbox and Chrome Version 80.0.3987.132 (Official Build) (64-bit)

0 Kudos
FC_Basson
MVP Regular Contributor

it must be some very strange issue on my side.  Another interesting phenomena is that the artifacts created are not kept at scale.

In this image I zoomed out from the original sketches.

And here I've zoomed back in

And looking at the map canvas in the DOM, you can see they are added as SVG paths.

Executing map.graphics.remove(map.graphics.graphics[0]) from the console will remove the first graphic, but not the associated artifact.

Executing map.graphics.clear() will remove the graphics as well as the artifacts.

0 Kudos
MAYUR2812
New Contributor II

We are experiencing the same issue in versions 3.35 and 3.37 too using the same ESRI sample. 
Most of the machines are not able to reproduce (working as expected).

The machine on which it reproduces is using the latest Chrome(92.0.4515.107).

Reproducible on EDGE too on the same machine. 

Note: When changed the API version to 3.30, it works as expected.

0 Kudos