IntegratedMeshLayer only loads some versions

226
3
07-26-2018 09:37 PM
SydeBurns
New Contributor

I have recently updated my ArcGIS javascript api from 4.6 to 4.8,

Some of the IntegratedMeshLayer's that I have been using no longer render.

They are hosted on a 10.41 server, I thought this might be an issue so made a copy on a 10.5 server and get an error stating "Service version is not supported."

The version on the 10.41 server works with the 4.6 js api but the version on the 10.5 server doesn't work with any API giving the above error.

Are there any guidelines or information on compatibility between server and api versions?

0 Kudos
3 Replies
RussellRoberts1
Esri Frequent Contributor

Hey Syde,

A few comments and questions

- Can you provide sample data and code? 

-screenshots, network and console logs can help us also debug this

- try to load the layer in Pro/Earth and compare to see the layers loading as expected

- recreate the data with the latest version of the tools (bentley, vricon, etc) 

Thanks!

Russ

0 Kudos
SydeBurns
New Contributor

I have created 2 viewers, one with the 4.6 API and one with the 4.8 API

4.8 API - IntegratedMeshLayer 

4.6 API - IntegratedMeshLayer 

You can see that in the 4.8 API the IntergratedMeshLayers do not load

The "10.6.1 IntegratedMeshLayer" is the layer from the demos, the others are hosted on our servers

0 Kudos
RussellRoberts1
Esri Frequent Contributor

One thing we noticed looking at the layers is that the 2 ContextCapture layers specify different coordinate systems for vertex (WebMercator) and index (WGS84), is this something you applied intentionally? The Yosemite example uses WGS84 for both which is what we currently expect.

0 Kudos