Graphics layer item limit /rendering problem in api version > 4.12

1675
12
Jump to solution
12-30-2019 07:36 AM
NettaBeninson
New Contributor III

Hi,

We are using graphics layers for many purposes.

When we checked v4.13, some layers appeared partially.

This happened only in big datasets.

My temp solution was to use featureLayer, and yet - it happened again in another part of our system.

I took the basic graphics example and managed to catch the point when the problem starts => more than 2205 graphic items.

I've created a simple codepen - https://codepen.io/nettaben/pen/QWwqbjy 

Change  `maxItemsV413` to 2204 to 'view' the markers ==> stops working when the number is greater.

If the api version is set to 4.12 - it is possible see more than 2205 points, while in v4.13 - it is not possible.

(change in the example).

UPDATE: not working with 4.14 as well.

Attached pic - our system partial view  

Codepen:#

1 Solution

Accepted Solutions
UndralBatsukh
Esri Regular Contributor

Hi there, 

I want to let you know that this issue is fixed at 4.15. You can test the fix for the issue with the next version. Please let me know if you run into problems. Please use this test app to check the fix.

Thanks,

-Undral

View solution in original post

12 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Netta,

   Move to 4.14 instead of 4.13.

0 Kudos
NettaBeninson
New Contributor III

Thanks, I've tried that already - not solving the issue.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Strange. Your codepen works for me when I change to 4.14

0 Kudos
NettaBeninson
New Contributor III

Send me a link to your new codepen maybe? did you change both css and js? 

Maybe it's also dependent on the system's hardware?

anyway it's a bug....

Maybe try adding 5000 items

0 Kudos
NettaBeninson
New Contributor III

It worked in another computer with 2205 items in v4.14 but not with 2207 items

0 Kudos
KenBuja
MVP Honored Contributor

When I tried it, it broke at 3087

RobertScheitlin__GISP
MVP Esteemed Contributor

Seems to be hardware related. As you can see that Ken and I are able to get past the 2205 mark and you were able to on another machine.

0 Kudos
NettaBeninson
New Contributor III

Still a bug. 

0 Kudos
UndralBatsukh
Esri Regular Contributor

Hi there, 

I am able to reproduce the issue you described and thank you for taking your time to create a simple reproducible case. We will investigate the issue and fix it. 

Thank you for reporting this issue,

-Undral