Gaps in Basemaps using Chrome

351
4
11-03-2020 10:14 AM
FlorianSteiner
New Contributor III

We are still using JS API 3.x and encountered this problem (gaps between the tiles of Basemaps), only when using Chrome:

It seems to have something to do with the scaling-parameters in Windows. Any ideas on how to solve this? It is also present in the ESRI-Sample (Basemap gallery), however not as pronounced.

We are about to migrate to JS API 4.x, but would love to resolve this issue quickly.

Thanks!

- Florian

0 Kudos
4 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Florian,

   Check you browsers zoom. Resetting it to 100% will fix this issue. Ctrl & + will zoom in and Ctrl & - zooms out.

0 Kudos
FlorianSteiner
New Contributor III

Thanks for your answer. Should have said that: No, that does not help.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

That is not what I find. See the attached image.

0 Kudos
FlorianSteiner
New Contributor III

Indeed, that is what I experience on one monitor, when I reset my Windows-scaling options. Since I use two different sized monitors, there are always these gaps on one monitor. That is why I assumed it had something to do with Windows' scaling - in general and for different screen sizes.

You should be able to reproduce that by setting the Windows scaling option. Here is a tutorial on how to do that, please refer to the part "How to change display scaling settings using custom values", at least thats how I did it: https://www.windowscentral.com/how-set-custom-display-scaling-setting-windows-10 

0 Kudos