ESRI JS API 4.X : FeatureTemplates widget creation fails when featureLayer already loaded

174
2
Jump to solution
03-19-2019 02:30 AM
NicolasGIS
Regular Contributor

Hello,

In my webapplication, I would like to create a FeatureTemplates widget under specific circumstances and I noticed that it fails when the featurelayer is already loaded in the map:

CodePen 

I know it's in beta so I hope it could be fixed !

Thanks,

Nicolas

NB : I am using arcgis webpack CLI for my web app and it took me a while to understand what was wrong because it fails silently contrary to using JS API from CDN.

0 Kudos
1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

Nicholas,

   It has already been fixed in 4.11 just swap out the the js API url to use 4.11 and you can test the fix.

View solution in original post

0 Kudos
2 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Nicholas,

   It has already been fixed in 4.11 just swap out the the js API url to use 4.11 and you can test the fix.

0 Kudos
NicolasGIS
Regular Contributor

Indeed ! That is a good piece of news

Thanks !

0 Kudos