Editor Widget for Portal Feature Layer isn't showing up (v3.x)

352
2
Jump to solution
09-29-2021 08:48 AM
SteveCole
Frequent Contributor

I'm starting to wonder if this is more a question for the Portal crowd but I'm baffled at this. I have a simple JS API app I built using the 3.x API to edit and add features to a layer in SDE. The original app workflow was that the two SDE layers were published to ArcGIS Server from Arcmap and then I used my JS app to perform edits and additions to the two layers. The layers and app are not public facing (they're behind the firewall).

Our IT wants to retire the server that was originally hosting the data so I needed to re-publish into our Portal install from ArcGIS Pro. I published to Portal from ArcGIS Pro (the data is still in the same SDE source location and NOT hosted inside of Portal). I then registered the app with Portal and added the needed code for the IdentityManager and OAuthInfo so that access can be granted to the data.

The app loads and the features display. The Editor widget does not. There are no errors in the console and, in fact, I know the Editor Widget does get created. When I do click on a feature, I finally get an error:

editorWidgetConsoleError.jpg

To me, this suggests that the editor widget does start and initialize but isn't finding any "editable" layers in the map (hence the undefined). But....how is this?

From inside of ArcGIS Pro, the source layer properties show that editing is allowed:

agsPro_properties.jpg

...from the publishing to Portal dialog, it shows that editing is allowed:

publishToPortalOptions.jpg

The one thing on the Portal side that I see is that "Create View Layer" does not appear as an option on the published feature layer's Portal Item page. So- has anyone else had to deal with this and figured it out??

 

Thanks-

Steve

0 Kudos
1 Solution

Accepted Solutions
SteveCole
Frequent Contributor

Postmortem- I was unable to resolve this issue, as described. Since editing did work through a Portal based webmap, I created a Portal webmap and then altered the 4.x Editor Widget Sample to match my environment. Not happy about it since editing using the 4.x Editor requires more mouse clicks than before but that's life, living in ESRI's world.

View solution in original post

0 Kudos
2 Replies
SteveCole
Frequent Contributor

Update- I don't believe this is a publishing issue with Portal. When I visit the Portal Item page for my feature layer, I choose "Open in Map Viewer" and the Edit button is present. I am able to edit attributes or add features.

0 Kudos
SteveCole
Frequent Contributor

Postmortem- I was unable to resolve this issue, as described. Since editing did work through a Portal based webmap, I created a Portal webmap and then altered the 4.x Editor Widget Sample to match my environment. Not happy about it since editing using the 4.x Editor requires more mouse clicks than before but that's life, living in ESRI's world.

0 Kudos