Editor widget and multipoint layer

1491
5
Jump to solution
08-04-2021 09:03 AM
MichailMarinakis1
Occasional Contributor

Hi all, 

we have noticed a weird behaviour when we use the out-of-the-box editor widget for JavaScript API. We have a multipoint layer. Our users would like to be able to create multipoints with either one single point or multiple points as a geometry for one feature. So we try to create a feature with only 1 point. 

We followed the following workflow:

  1. we start add a new feature,
  2. we start creating the geometry, 
  3. we click once to place a point on the map, 
  4. we press enter, nothing happens
  5. we click to add a second point
  6. we press enter
  7. workflow progress to attribute values

Similar behaviour with double click. We tried to terminate the geometry workflow by double click on the first point and it was not possible. 

The question is: Is the creation of a single point feature in a multipoint feature layer supported from the editor widget? Or will be supported ;-)?

 

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
JoseBanuelos
Esri Contributor

Hello @MichailMarinakis1 ,

This issue has been resolved in version 4.21, which releases towards the end of the month! Thanks again for bringing this to our attention.

Thanks,

Jose

View solution in original post

5 Replies
JoseBanuelos
Esri Contributor

Hello @MichailMarinakis1 ,

This seems to be a regression as of version 4.19. What version of the JSAPI are you using? Can you check with version 4.18 please and let me know if this works for you? 
I just checked with version 4.18, and you should be able to create a single point feature with the Editor widget on a multi-point feature layer.

The shortcut to add the feature will be the "c" key in version 4.18. We switched to the "Enter" key in 4.20. You can also just double-click to complete the operation as well as you mentioned you tested.

Thanks,

Jose

0 Kudos
MichailMarinakis1
Occasional Contributor

Hi @JoseBanuelos , 

thank you for the response!

we are using version 4.20. You are right, we have tried the version 4.18 with the "c" key or double click and it works properly. It does not work for 4.19 and 4.20. 

Is it going to be fixed in 4.21? We cannot go back to 4.18 because we have introduced already the snapping mechanism to the customer.

 

 

0 Kudos
JoseBanuelos
Esri Contributor

Hello @MichailMarinakis1 ,

Thanks for the confirmation! This is a regression so we are investigating this, and hope to get this in for 4.21. This issue is coming from the SketchViewModel, but either way we are working on it. Thank you for bringing this issue up with us!

Thanks,

Jose

0 Kudos
JoseBanuelos
Esri Contributor

Hello @MichailMarinakis1 ,

This issue has been resolved in version 4.21, which releases towards the end of the month! Thanks again for bringing this to our attention.

Thanks,

Jose

MichailMarinakis1
Occasional Contributor

Hi Jose,

Thanks a lot for the reply and for the good news! Kudos to the team for managing to include the fix in the next release. Good stuff!

Cheers,

Michail