arcgis-js-api @types

260
2
Jump to solution
10-29-2018 02:42 PM
JesseAdams
New Contributor III

Hello,

I'm trying to utilize Angular CLI with the with newest version of the JS API (4.9) along with Typescript and @types/arcgis-js-api (4.9.0).  I'm running into a build issue that can be repeated on multiple machines.  There appears to an issue with the "AbortSignal" variable in the typescript definition file.  Here is the error thrown:

I can get around this issue by commenting out the AbortSignal variable in the definition file:

However, this doesn't help during automated builds.

Is this a bug with typescript definition file?  Any suggestions would be greatly appreciated.

Thank you,

0 Kudos
1 Solution

Accepted Solutions
ReneRubalcava
Frequent Contributor II

Try updating to the latest version of TypeScript in your application per this post in this thread.

https://community.esri.com/message/803692-abortsignal-error-with-typesarcgis-js-api-49-and-esri-load... 

I think the ng-cli comes with an older version of TS by default.

View solution in original post

0 Kudos
2 Replies
ReneRubalcava
Frequent Contributor II

Try updating to the latest version of TypeScript in your application per this post in this thread.

https://community.esri.com/message/803692-abortsignal-error-with-typesarcgis-js-api-49-and-esri-load... 

I think the ng-cli comes with an older version of TS by default.

0 Kudos
JesseAdams
New Contributor III

That worked to upgrade to Typescript 2.9 and Angular CLI version 6.x.

Thank you!

0 Kudos