Arabic TextSymbol not being displayed in JavaScript API

2175
2
Jump to solution
10-07-2019 11:31 PM
AsmaYasin1
New Contributor

I'm trying to let the user add labels on the map as part of a sketching tool.

Whenever the text is composed of all Arabic characters, say "مرحبا", the graphic is not being shown on the map. If I add any other non Arabic character to the text, the graphic will be displayed correctly.

P.S. the graphic is added successfully to the GraphicLayer, but the problem is in displaying it on the map.

I even tried using a sample code from your library and replaced the text of the textSymbol with Arabic characters and got the same result. This is the sample I used.

I'm using JavaScript API version 4.12.

Please advise on the described issue.

0 Kudos
1 Solution

Accepted Solutions
UndralBatsukh
Esri Regular Contributor

Hi there, 

This issue will be fixed at 4.14. But you can test the fix with our `next` release. 

See this sample for the fix. 

-Undral

View solution in original post

2 Replies
Noah-Sager
Esri Regular Contributor

Hi Asma,

Thanks for reporting this issue. I can reproduce the problem and will investigate. The only short-term workaround I found is to introduce an extra space in the text string, so that the Arabic characters display without having to display other characters as well. Will update the post here when I have something to share. 

0 Kudos
UndralBatsukh
Esri Regular Contributor

Hi there, 

This issue will be fixed at 4.14. But you can test the fix with our `next` release. 

See this sample for the fix. 

-Undral