Select to view content in your preferred language

Street Address Locator 10.4

2445
2
Jump to solution
07-27-2016 03:06 PM
TomSellsted
MVP Regular Contributor

Greetings,

After my upgrade to 10.4.1 I am still struggling with address locators.  I have built a street address locator using US Dual Range Addresses style, style release 10.4.  Our streets feature class covers our entire county. 

Prior to this release, I was able to enter a simple address "129 N 2nd St" and get a list of candidates, typically with the entered address being the top score.  Now I get no results of any kind, until I enter a city or zip code.  I have lowered the "minimum candidate score" and "minimum match score" to 1 which is ridiculous, but I still don't get any results without a city or zip code.

Does anyone have any suggestions or maybe I have found a bug?

Regards,

Tom

1 Solution

Accepted Solutions
SubuSwaminathan1
Occasional Contributor

Tom,

We are also facing the same issue on 10.3.1 ArcGIS server. I was hoping it was fixed in 10.4.1 as this bug was reported in the  10.4.1. issues addressed list under the geocoding services topic. If you are still seeing it, esri needs to be notified.

BUG-000093169

The ArcGIS for Server 10.3.1 US Dual Range Addresses Geocode Service fails to return ‘findAddressCandidates’ results when the address does not include the zip code, match with no zones is set to ‘yes’, and the location parameter is provided and close to the actual feature with certain datasets.

Subu

Pierce County

View solution in original post

0 Kudos
2 Replies
SubuSwaminathan1
Occasional Contributor

Tom,

We are also facing the same issue on 10.3.1 ArcGIS server. I was hoping it was fixed in 10.4.1 as this bug was reported in the  10.4.1. issues addressed list under the geocoding services topic. If you are still seeing it, esri needs to be notified.

BUG-000093169

The ArcGIS for Server 10.3.1 US Dual Range Addresses Geocode Service fails to return ‘findAddressCandidates’ results when the address does not include the zip code, match with no zones is set to ‘yes’, and the location parameter is provided and close to the actual feature with certain datasets.

Subu

Pierce County

0 Kudos
TomSellsted
MVP Regular Contributor

Subu,

Thanks very much for your quick response.  I thought that I had poured through all of the geocoding options.  I did not have the "match with no zones" marked to yes.  Once I set it, things are working as before. 

I don't recall having to set the "match with no zones" parameter.  The original locators were created some time ago and just rebuilt as updates were made.

Regards,

Tom