Enhanced Search Widget Version 2.23 - 03/29/22

379655
2776
07-14-2014 03:57 PM
Labels (1)

Enhanced Search Widget Version 2.23 - 03/29/22

Live Preview Site

Web AppBuilder for ArcGIS | Help - Enhanced Search widget

 

List of the latest enhancements and changes:

  1. Fixed issue with relates
  2. Fixed issue with search fields that have sub types applied'
  3. Major changes to the widgets config.json to remove redundant objects (i.e. values > value now becomes just an array of values) This prep work to make your existing eSearch configs work with the coming Experience Builder eSearch widget.

 

Older enhancements or changes

Check the "Older enhancements or changes.txt" in the download for a complete list.

 

Older Versions

Last 2.21 version

Last 2.17 version

Last 2.13 version

Last 2.12 version

Last 2.11 version

Last 2.9 version

Last 2.7 version

Last 2.6 version

Last 2.5 version

Labels (1)
Attachments
Comments

Thanks Robert. Worked perfectly.

Hi Robert,

Love the eSearch Widget! I'm trying to download the 2.17 version. The current attached link downloads as version 2.13 (manifest.json) with a help htm for 2.12 (eSearch_Help.htm). I just want to make sure i'm using the correct version. Maybe I'm missing something? Can you point me to a link for 2.17? 

Thanks again for the awesome widgets!!!

Ned Cake, TLCGIS

 

Ned,

  Indeed there was a file issue in the zip. I have fixed that issue now. Thanks for letting me know.

OK I've gotten the widget downloaded and configured in my app but when I click on the result tab and click on the ellipses I don't the "export to csv file" option. Is this not a feature yet or what I am doing wrong?

@AlexMarrero 

Do you have the 'CSV export' option checked for that layer in the widgets layer settings?

Robert,

Thanks for pointing that out. I got it now!

Thanks,
Alex

Hi, Is there anyway to configure the eSearch widget that allows the user to enter a Lat/Long Coordinate and returns the search? Very similar to Search By Shape "Point", but uses a coordinate.

I have a requirement that has to met this. Have a simple polygon product index, the user has coordinate info of change to a product, they would like to search with coordinate to determine what products are affected. 

Or does anyone know of another widget that would achieve this?

Thanks in advance

Brendan

Anonymous User

I think this is what you are looking for.

Location Widget - Esri Community

Robert, 

I love your widgets and so do our users....I'm currently trying to install eSearch 2.17 on my 10.8.1 portal and encountered the following error?  I am using the eDraw and Print Plus widgets on the same viewer with no issues.  I have also used previous eSearch widgets on previous portal versions with no issues.  Any idea what's up?  ThanksInkedcreatewidgeterror_LI.jpg

Hello Robert,

First off, this is an amazing widget! But I'm having some issues with the predefined Value list keeping the values. After I click OK, then go back to the list, it clears out the value part while keeping the Label side. Has anyone had this issue before, and is there a possible fix?

 

Thank you, John

WithValue.PNG

WithoutValue.PNG

Updating an app to WAB 2.19 with eSearch 2.17 and I don't see the "Limit search to map extent" checkbox.  I figure there's probably a config option for it, but if there is, I'm not seeing it.  Am I having a huge 'duh' moment here and missing something obvious?

I removed the following from style.css to get it back but feel like I might be missing something.

.jimu-r-row.play-section .col-2-3 {
  display: none;
}

 

@RyanKelso 

You are correct that is how you currently have to edit the widget to make it show. Right now I have no recollection on why that css rule was added in the style.css. 

Is it possible use TAB key to navigate through the search fields in orders as shown below? 

Ehanced_Search_Tab.png

@LixinHuang 

I have tried to get tabbing working properly in this widget without any success.

Hi Robert,

Is it possible to disable the auto zoom when the mouse pointer hovers on any of the search results? 

@LixinHuang This widget has no such feature that will auto zoom to the graphic when you hover over a search result...

@RobertScheitlin__GISP  If there are multiple search results, when uses hover the mouse on one of them, e.g., the one highlighted in green rectangle, the map will automatically zoom to that result. We want to disable that function. 

eSearch_Auto_Zoom.png

Good morning Robert,

Updating an app to WAB 2.19 with eSearch 2.17 and the graphic search options are invisible even after I adjusted the widget width. would you please help? BTW, the App theme is launchpad.

Thanks,

 

chena_0-1620910319068.png

 

@LixinHuang I am still struggling to grasp what you are saying as I am not aware of any code that I have that will zoom the map to the result on the map when you just hover over the search result in the widget without clicking on that result. Is what I just described what you are seeing. If so has any code changes been made on your end???

@RobertScheitlin__GISP We hired a consultant to help us build the web applications with the Enhanced Search widget you developed. The consultant may have changed some codes. We checked the test site for your widget. You are right. There is no auto zoom function on the search results. It seems that we need to tweak the code to disable the auto zoom function. Can you help us point out the section of codes which handle zoom to selected result? Your help would be greatly appreciated. 

@chena  I just tested in 2.19 using Launchpad theme and did not see the issue you are showing. Is you browser set for a different locale (meaning it displays in a language other than English)?

@LixinHuang This is the default code for the search results mouse over handler. This is likely where they made the change in the widget.js

_overResultItem: function (index, item) {
  this._addSelectionGra(item, true);
},

 

Hi Robert,

Thanks for looking into that. below it's the language setting in google chrome.

chena_0-1620917821455.png

 

@chena,

   Strange I am not able to reproduce what you are seeing. Any additional info you can provide? Is the widget in the achorbar controller? Have you tried creating a new fresh app and see if you get the same results?

Hi Robert,

It's strange that when I checked the first option, the search button displayed and when I selected the blank area all texts show up. Will try to create a fresh app.. Thanks for your time

chena_1-1620930412592.png

 

@chena  It appears to me that you have maybe changed some css rule and the font is white thus it is not showing. The fact that the text is offset, bold and white lead me to believe that you might have a non-specific "label" css rule that is interfering with this widget. 

Hi Robert,

You are a genius! I created a new site without making any css rule change, everything works perfectly. Thanks again!

Hi Robert, 

First of all, I am using your esearch widget to much success in my applications, thank you so much for making it! 

My question and problem is in relation to the "add to current results" search option as well as the spatial search tab of the widget.

The layer breakdown is as follows:

  • Protected Sites A
  • Protected Sites B
  • License Applications

In one of my viewers, the users wish to be able to search the "Protected Sites" layers by site name and then have the option to download a csv of all of the license applications that intersect with the protected site they just searched for. I used the value search and the spatial search tabs of the esearch widget for this and it worked great when using one of the protected sites layers for the intersection.

However, a user asked if they could combine value search results from Protected Sites A and Protected Sites B together, prior to the intersection, so that the csv they export will contain all of the license applications that fall within their results for Protected Sites A and also those that fall within their results for Protected Sites B.

I went to test this - using the "add to current results" search option in the widget and am seeing very weird behaviour.

  • The map symbology for all value search results will change to the most recently searched layer (Protected Sites A results should be pink, but will change to the green of Protected Sites B if those results are combined) - while the results tab will show the symbology the layers are meant to be.
  • The web map popups for Protected Sites A will take on the style, layout, and included attributes of Protected Sites B (but try to plug in the attributes from Protected Site A where attribute references match)
  • The spatial search intersection will (seemingly) randomly grab SOME of the License Applications that fall within the selected sites but not all of them

I realize that combining layers like this might be a feature that is outside the intended scope of this widget, but I just wanted to check in - in the chance that it should be working. 

Should I be able to combine layers like this in the esearch widget? Or should I tell users to use one layer at a time?

@KellieH 

The widget is designed to search one specific layer at a time so No you can not select one or more features from Protected Sites A and then add one or more feature from Protected Sites B before doing the spatial selection on License Applications.

Thanks for the confirmation @RobertScheitlin__GISP that makes complete sense.

Is there an edit I could make that would clear the results tab automatically when a user selects a new search layer from the drop down menu? I'm hoping to avoid future users trying what I tried. Or is my best bet just adding in a note telling users not to try to combine layers? 

@KellieH 

Sure you can try adding this  (lines 2 - 4):

      onAttributeLayerChange: function (newValue) {
        if(this.currentFeatures.length > 0){
          this.clear();
        }
.....

 

 

@RobertScheitlin__GISP Works perfectly, thank you!

Hi Robert,

Sorry to come back with another question so soon! I have noticed that when using "Add to current results" when the "Add result as operational layer" option is active,  the webmap popups will lose some of their information (in my case Intersects arcade expression results). This does not happen when the results are not added as an operational layer. 

This was happening before I added the edit to clear results when switching the search layer, but I just hadn't noticed.

For now I have hidden the search options menu, but I was wondering if this is something that is fixable? And if so, where in the code I should look to try to get these popups to pull across all of the attributes when added as an operational layer?

Hi:

How do I properly configure the esearch widget to use the popup from my web map? I selected use popup from web map in the configuration settings and gave it the same name as my web map layer although the popup never showed. 

 

BrandonPrice2_0-1623969886632.png

 

Also, how can I run and show intersect result of addresses intersected by a parcel without clicking clicking the intersect button?

 

BrandonPrice2_0-1623970391855.png

 

@BrandonPrice2 , to use the layer popup configured in the web map you choose Use Popup from "Web Map" in the layers setting when configuring the search layer in the eSearch widgets settings. The layers URL need to be identical to the url that is configured in the webmap (i.e. protocol and CaSe).

Hi @RobertScheitlin__GISP:

The web map popup is showing. I had to check "Disable search results popup". The issue I am now having is the related fields in my popup are not showing. I configured the related fields using arcade expressions. The relates are between two different flat tables and an address point layer which are all in my web map. The relates are all done in arcade and were not the result of a published related map service. I would provide you the web map url although you would not be able to see the related data from the flat tables anyway because they are hosted on a private ArcGIS Server. What is the reason the related fields are not showing and what can I do to fix it?

BrandonPrice2_0-1624062420317.png

 

If you click on the point itself it still shows correctly

BrandonPrice2_0-1624070115403.png

It only happens when the popup is triggered by clicking the result

BrandonPrice2_1-1624070214002.png

 

Here is the link to the web map: https://lacounty.maps.arcgis.com/home/webmap/viewer.html?webmap=c852a8eb23d74122851917613c9c5102

I realized I could also use the attribute table and not just the enhanced search widget to achieve triggering a popup by clicking on the results in a table. I just have to figure out how to configure the default "filter by map extent" button in the attribute table to filter by by selected parcel like how I have it in the enhanced search widget. The related fields do show in the popup when double clicking the result in the attribute table to trigger it.

@BrandonPrice2,

When I use the web map link you provided I get this error:

The layer, House Number Database, cannot be added to the map.

and

The layer, PDF Archive, cannot be added to the map.

@RobertScheitlin__GISP:

I am aware. The tables are not public. They are on a private ArcGIS Server and can only be viewed internally. The popup is still showing blank internally when triggering it by clicking a result in the enhanced search widget although the popup does not show as blank if you click on it. I think the attribute table could be another possibility with a little re-configuring. I will explore how feasible that is. I created a separate post asking for advice here: https://community.esri.com/t5/arcgis-api-for-javascript/web-appbuilder-dev-re-configure-attribute-ta... 

@BrandonPrice2 reading your post, makes me wonder if the arcade that you wrote isn't cooperating with the WAB Dev because of the difference between the two languages... meaning the WAB Dev and the web app builder are Java 3, the arcade you wrote might be in java 4. We had a similar issue with the pop-ups not showing what we had configured in arcade when the layer was brought into our web app builder developer apps. I know this comment doesn't help solve your issue, but it might provide insight into why your related data isn't showing up... 

That makes sense. Issues trying to use code from both ArcGIS API 3.x and ArcGIS API 4.x in one app could be it. I did not realize Arcade was written in 4.x. 

I found from this page that ArcGIS Arcade is written independent of ArcGIS JSAPI 3.x or 4.x. The page has a chart indicating that the current version of Arcade, 1.13, should work with the current version of Web Appbuilder. Web Appbuilder was written in ArcGIS 3.x as you said which I confirmed here. I did not know this. I thought it was written independent of the ArcGIS APIs. Knowing this will make things easier. I can now customize web appbuilder developer apps using the 3.x API freely without being confined to widgets.

@BrandonPrice2 Good find about arcade! I will take a look at those links. I might have been crossing my wires with what I discovered and shared above. Because of the 3 to 4 jump, the new web map viewer configurations don't always work with the WAB, so you have to keep working in the Map Viewer Classic. I had created a bunch of arcade expressions in a web map (new), and then tried to use the map in WAB and several layers didn't cooperate. I think I was getting that fact and the arcade I was using in that map mixed up with compatability.

Good luck with your work!

Hi @RobertScheitlin__GISP ,

Just wondering if there's a v2.4 for your eSearch widget? We're currently still on Enterprise 10.5.1.

I tried substituting 2.4 into the download URL (https://gis.calhouncounty.org/WAB/V2.4/other/eSearch.zip) and went through all the steps to host the widget on our web server then register it in Portal. However, on the ‘choose custom widget’ interface of the Portal app, the widget is present but the icon is blanked out. When I select it and click ‘OK’, nothing happens and I stay on the same interface.

PropertiesCurtin_0-1624591237072.png

 

I was wondering if this issue is caused by the widget itself or something on my end. I'm a complete newbie with custom widgets, never added one before and am struggling to find other v2.4 widgets to try and replicate this issue. Would greatly appreciate any advice!

@PropertiesCurtin ,

You should be good using the 2.4 url like you did. It would appear that you have some issue with you placement/install of the widget. 

I am NOT a Portal (ArcGIS enterprise) user so I can not talk from experience. But something to check is that your folder structure is like this and there is Not an additional folder in there before the Widget.js file:

[portal install]\widgets\eSearch\  > then you have the Widget.js and other files directly in this folder and not another eSearch or some other folder first.

Thanks for the reply @RobertScheitlin__GISP . Still no dice, hopefully I get to use your lovely widgets eventually!

Hi @RobertScheitlin__GISP , me again. I managed to get the widget to work beautifully! I've come across a thing when selecting features though. Points aren't highlighted when selected by the widget - by value or shape. The symbology just stays the same when selected. Polygons and lines show up fine though. I've tried configuring the 'Edit Default Search Symbology' to no avail. Any guesses to why this is?

 

@PropertiesCurtin  Sounds like you have an issue with the url path to the picture marker symbol used as the default symbol for points. Do you get any errors in the web console of your browser?

Version history
Last update:
‎03-29-2022 01:24 PM
Updated by: