ArcHydro Problem Solvers

Jump to solution
01-19-2012 06:10 AM
Labels (1)
Occasional Contributor III
This is a collection of actions I've learned to take when I'm having problems with ArcHydro or HEC-GeoHMS. I'll add to the list when I find more.

  1. Make sure the Geoprocessing extents include the whole project: Go to the Geoprocessing menu>Environments...>Processing Extent. Under Processing Extent choose a layer that you know covers the full extent of the waters you are processing and click OK. This should ensure that the processing extent is large enough to do what you want.

  2. Delete everything you can in your temp folder: Mine is C:\Users\mboucher\AppData\Local\Temp. Get out of ArcMap first to clear temp files related to your project. You can do this without getting out of ArcMap through the ArcHydro Toolbar under ApUtilities>Additional Utilities>Clean User's Temp Folder.

  3. Make sure your Target Locations are correct: Under ApUtilities>Set Target Locations, make sure the HydroConfig and they GeoHMSConfig Targets make sense. The raster data should go to the project folder vector data to a geodatabase. The raster data will go to a folder in the project folder with the dataframe name and the vector data to a feature data set with the dataframe name. Through the ArcHydro Toolbar under there is a function to reset the target locations: ApUtilities>Additional Utilities>Reset Target Locations. I've not tested this to see if it corrects everything.

  4. When working on a complicated model, don't use the model mxd for your presentation map. It just adds baggage to an already "heavy" mxd.

If you have additional actions or clarifications on these, please chime in.
1 Solution

Accepted Solutions
Occasional Contributor III

I've started a practice that seems to make many errors/crashes go away.

Layers/rasters needed for Arc Hydro are:


      • rawdem (Extracted by mask from county-wide dem for each project. Set processing extents using this or mask ploly)

      • agreestream*

      • innerwalls*

      • outerwalls*

*I do work all over my County and so have county-wide "master" geodatabase for these that I use on all my Arc Hydro Projects.


      • BatchPoints

If I have these layers, I can recreate the hydrologically correct DEM (HC DEM) anytime I want and re-delineate the watersheds.

So my practice is this: As I'm developing my HC DEM, and have to modify the agreedem, innerwalls, outerwalls layers, I can save the BatchPoints to my project folder and then delete the geodatabase and folder with rasters in it (Target Locations). This starts everything fresh and new. Then I can use model builder to reprocess the watersheds. When I'm ready to re-delineate the watersheds, I copy the BatchPoints into the geodatabase and set the BatchDone value to "0".

I run the watershed delineation, etc. via the Arc Hydro menus though I could possibly do this via Model Builder also. Since I've started doing this (and following solutions in the postings above on this thread), my crashes and errors have all gone away! Here is the ModelBuilder model for my latest project. I don't use outerwalls on this project, but that could be added.


View solution in original post

102 Replies
New Contributor
Thanks Mark.  Very helpful.
0 Kudos
Occasional Contributor III
As an addition to the earlier tips. I just found that when I put the mxd in a folder with a simple name and no spaces, the Terrain Processing with Arc Hydro ran without a hitch.

Today I happened to look in the "log" file in the raster folder for the project and saw that a raster name was cut off. In the example below you can see that the flow accumluation file name was cut off after the "f".
201201251045   0     1     0mboucher P:\GIS USERS - Projects\Arc Hydro\Research\Project2\Fdr = FLOWDIRECTION(P:\GIS USERS - Projects\Arc Hydro\Research\Project2\Fil
201201251050   0     1     0mboucher P:\GIS USERS - Projects\Arc Hydro\Research\Project2\Fac = FLOWACCUMULATION(P:\GIS USERS - Projects\Arc Hydro\Research\Project2\f

Putting the project in a simpler folder name with no spaces resluting int the "log" file looking like this:
201201251407   0     0     0mboucher P:\ArcHydro\Test\Project4\Fdr = FLOWDIRECTION(P:\ArcHydro\Test\Project4\Fil,  #, NORMAL)201201251407   0     1     0mboucher P:\ArcHydro\Test\Project4\Fac = FLOWACCUMULATION(P:\ArcHydro\Test\Project4\Fdr,  #, FLOAT)
201201251407   0     0     0mboucher P:\ArcHydro\Test\Project4\str = CON(C:\Users\mboucher\AppData\Local\Temp\AH20120125140707\condgeo, C:\Users\mboucher\AppData\Local\Temp\AH20120125140707\condgeo)
201201251407   0     1     0mboucher P:\ArcHydro\Test\Project4\StrLnk = STREAMLINK(P:\ArcHydro\Test\Project4\str, P:\ArcHydro\Test\Project4\Fdr)

You can see that their is much more to the file name and some other info. I don't know if there is a limit to the length of the path or if some functions don't like the spaces in the path. Eitherway, I'm going to keep things short and spaceless for a while and see if that works. I've been aware of naming problems when there were spaces, but that hasn't seemed to cause a problem before. I've always muscled through it.

With this change in practice, I used the canned terrain processing model with no problems.
Occasional Contributor III
One more thing... I've gathered from other posts that when using GeoHMS, things work better if you turn off background processing. Go to Geoprocessing>Geoprocessing Options... and uncheck "Enable"  under "Background Processing".
0 Kudos
New Contributor

I recently had a problem using the Stream Definition tool while delineating catchments. This problem started out of the blue, and  I'd been using the same process I've used repeatedly in the past (with success).

I followed all of the recommended actions (clear temp folder, set target locations, new mxd, restart the computer, even updated to version, but was still getting the following error when running Stream Definition:

Failed to execute. Parameters are not valid.

     ERROR 000860: Input true raster or constant value: is not the type of Composite Geodataset, or does not      exist.

     Failed to execute (Con).

     Failed at Tue Apr 14 09:16:34 2015 (Elapsed Time: 0.02 seconds)

System.Runtime.InteropServices.COMException (0x80004005): Error HRESULT E_FAIL has been returned from a call to a COM component.

   at ESRI.ArcGIS.Geoprocessing.GeoProcessorClass.Execute(String Name, IVariantArray ipValues, ITrackCancel pTrackCancel)

   at ESRI.APWR.ApHydro.ArcHydroOp.StreamDefinition(ApLayers& aplayers, Double numCells, ITrackCancel trackCancel, IGPMessage messages, String& exMessage) in C:\Builds\HydroSolutions\10.3_ArcHydro\Sources\ArcHydroTools\src\ApHydro\ArcHydroOp.vb:line 63795

Failed to execute (StreamDefinition).

Failed at Tue Apr 14 09:16:34 2015 (Elapsed Time: 0.12 seconds)

I turned background geoprocessing ON, and the Stream Definition tool worked correctly. HOWEVER, this worked with a FAC grid that was created with background geoprocessing OFF. I tried the process from the beginning with BGGP OFF, and the resulting FDR grid contained more than the normal 9 values.

At least for me, it seems I need to turn BGGP OFF in general, and turn it ON when running Stream Definition. Also unsure why this problem started out of the blue, but wanted to put the information out there in case anyone else is having the same issues.

0 Kudos
Occasional Contributor III
Just to consolidate, Stacie Wolny submitted another one today:
0 Kudos
Occasional Contributor III
0 Kudos
New Contributor
Errors when running tools from HEC-GeoHMS toolbar.

Do not enable the Background Processing option on the Geoprocessing Options editor.

1. Go to Geoprocessing, Geoprocessing Options�?�
2. Make sure the Enable checkbox is not checked under Background Processing.

If background processing was checked then start the GeoHMS project over.
0 Kudos
Occasional Contributor III
0 Kudos