Issues with Inconsistencies in Shortest Path Trace

305
1
02-15-2021 08:22 AM
JackDaniels519
New Contributor

Hello,

I am relatively new to ArcGIS and I'm currently working on creating a trace network showing rivers in the UK. When initially developing the trace network I received a number of errors due to junctions being placed in the middle of line features (Error Type 13: Midspan connectivity not allowed). This could not be solved by allowing complex edges, as system junctions were created in places where there was no connectivity. I used the point errors generated by the Trace Network in the "Split Line at Point" Tool to generate a new line feature class, and then recreated the Trace Network using this. I thought this had solved the problem as no errors were received when the network was validated.

However, I am now getting some strange inconsistencies when running a shortest path trace. For example, in the attached image I am trying to run a trace between points 1 and 4. I know the points are connected (checked using a connected trace), but I am receiving the error "WARNING 002535: No path was discovered". I have also run shortest path traces between all other combinations of these points (1-2, 1-3, 2-3, 2-4, 3-4) using exactly the same parameters, with no issues. Similar inconsistencies are occuring at a number of other points in the network, but I am not sure why.

A small sample of tha data/project used to create the image is attached.

Apologies if this is just a result of my lack of experience - but I'd appreciate any suggestions.

0 Kudos
1 Reply
JonDeRose
Esri Contributor

@JackDaniels519 Thank you for the details.  I've taken a look at the data you have shared and can reproduce the issue.  The issue appears to be related to the location of the starting point in a loop; however, I have not yet been able to determine the cause.  I've created an issue to investigate and can provide more insight once we've had an opportunity to review further.