Enter points on trace network flow is very slow

240
2
03-23-2021 04:26 PM
curtvprice
MVP Esteemed Contributor

This is a complaint and a workaround I ran into with the Trace Network. First I want to say this is great and looking forward to more from this new functionality! 

I have found that adding points when clicking on the map is very slow (sometimes, not always). If I wait a long time (30 seconds) the point shows up. I have a workaround however, if I select an feature and click the other button (Add selected) that works instantaneously.

Just a report for the trace network team.

Thanks again for the tool @JonDeRose -- clearly your team has been re-imagining the interface with the Pro design in mind and it's looking quite "Prothonic" to me (that's a compliment) as I convert old Geometric Network tutorials to the new tool.

 

0 Kudos
2 Replies
JonDeRose
Esri Contributor

Thanks @curtvprice To confirm, this is seen when you are attempting to place a new starting point in the trace locations pane?  Is there any change in behavior depending upon the network feature you place the starting point on?  Does the feature display in the the pane pane before it is displayed on the map?

Working with a large NHD sample dataset I am not able to reproduce similar behavior but I'd like to get a better idea of what you are encountering.  Could you share the diagnostic log from the ArcGIS Diagnostic Monitor while performing the action?  Open ArcMon by pressing   Cntrl + Alt +M, enable Diagnostic log (logs to C:\Users\<user>\Documents\ArcGIS\Diagnostics\ArcGISProLog.xml) and attempt to place the starting point.

JonDeRose_1-1616605387409.png

 

Tags (1)
curtvprice
MVP Esteemed Contributor

Yes, was happening while I was placing points. Basically nothing happens, when it finally does the point appears on the map and the list at the same time. Adding selected worked instantly as I said, but adding points by clicking on the map was equally slow anywhere on the map.

This a very small data set: 4300 edges, 3300 junctions.

Today I can't reproduce today.  May be one of those things where turning it off and turning it on again fixed the issue.  I will let you know if it re-occurs and I have something new to report.