remap function on raster mosaic not working

185
0
10-07-2021 11:32 AM
Labels (1)
LizGoldman
New Contributor

I'm trying to apply a remap function to a virtual mosaic I have stored in a geodatabase and it is not working properly. I've performed remaps on other mosaics many times, but I have a new dataset and the remap is acting like the pixel values are missing.

More details: the dataset is a binary 0, 1 and I'm trying to remap the 1 values to 40. I have a remap row with 1 min and 2 max and output 40. When viewing the mosaic with the remap applied in ArcMap and the 'change missing values to NoData' unchecked, the 1 pixel values are still 1. If I check 'change missing values to NoData' everything changes to NoData. 

I've tried to run a 'zonal statistics as table' with the mosaic + remap and it IS reading the remap in this analysis. It is summing the pixels and treating them as value 40. But when I use this in a script that is expecting values of 40, it is being read as values of 1.

Any ideas? This is a large raster dataset, but I've tried clipping it down to a very small size for testing and it is behaving the same way.

0 Kudos
0 Replies