Location Referencing Tools don't show centerline direction or the From and To Measure symbology (green cross & red X)

612
5
Jump to solution
02-06-2024 10:13 AM
AlexanderShields_AZ
New Contributor II

I'm used to seeing the selected centerlines highlighted in red with an arrow showing the centerline direction, as well as a green plus-sign and a red X on the map to show the From and To Measures when using any of the Location Referencing tools. 

Lately, this symbology has not been showing up. I've tried updated ArcGIS Pro and republishing the LRS Service to no avail. That symbology has been very helpful in making sure my edits are precise. What can I do to get this symbology working?

AlexanderShields_AZ_1-1707243050248.png

 

0 Kudos
1 Solution

Accepted Solutions
AlexanderShields_AZ
New Contributor II

Thank you Ayan and Amit for your time and your replies. There has since been a new update since I updated earlier this week and that has resolved my issue with the location referencing tool symbology. Version 3.2.2

View solution in original post

5 Replies
AyanPalit
Esri Regular Contributor

@AlexanderShields_AZ The start (green) and end (stop) graphics to show route editing segments are very much there. What is the ArcGIS versions used? Also the screenshots suggests that centerline does not touch the routes. In this case, the start and end of realign is not auto-detected and could be the reason. 

Ayan Palit | Principal Consultant Esri
0 Kudos
AlexanderShields_AZ
New Contributor II

Where do you see the start and end symbology? They're supposed to display in the red circles I drew over the existing route, right? Maybe I'm wrong and they're supposed to display over the beginning and end of the selected centerlines, either way, I can't see them. 

Yes, the centerlines do not touch, that is normal for our database, we use the routes to represent any road that shares the same name throughout the city. Because of that it does not auto-detect the measures and we enter them manually by clicking the "Choose measure from map" button that is next to the From and To Measure text boxes.

Still, when we manually enter the From and To Measures, it should show the start and end symbology. It always has, up until now.

0 Kudos
AmitHazra
Esri Contributor

@AlexanderShields_AZ I will echo my colleague's post with regard to functionality expected in ArcGIS Pro Location Referencing Realign edits. Here is an example where I am filling in a gapped route with a new centerline:

AmitHazra_0-1707247474338.png

 

Please check that you have the correct centerlines selected and chosen. You may also test a simple touching extend or touching realign to see if the issue is related to the not-touching scenario you depicted in your original post.

-amit@esri  
Esri Transportation LRS Team 
 

 

 

0 Kudos
AlexanderShields_AZ
New Contributor II

It definitely isn't related to the not-touching scenario. I just tried making a fake route with a gap on a continuous centerline. When I used the realign tool on it, it does auto-detect the measurements, but still no symbology is displayed.

AlexanderShields_AZ_0-1707248328194.png

Also, you can see that the number label indicating the centerline number does not show either (as it does in your screenshot), and neither does the arrow showing centerline direction.

I am 100% certain I have the correct centerlines selected. This clearly seems to be a display/drawing issue.

0 Kudos
AlexanderShields_AZ
New Contributor II

Thank you Ayan and Amit for your time and your replies. There has since been a new update since I updated earlier this week and that has resolved my issue with the location referencing tool symbology. Version 3.2.2