Accessing Organizational Items with OAuth

03-19-2023 09:23 AM
Labels (3)
New Contributor

So I've been following the C++ tutorials for the Qt framework and deploying to an iPhone simulator. I can successfully access and display public items from my organization's ArcGIS Online portal. However, any attempt to display a map, feature layer, etc. that is set to "Organizational" sharing level does not succeed.

I followed the OAuth tutorial. I've added the "AuthenticationView" within my QML, and indeed the correct page opens to allow me to enter my credentials for OAuth for my organization's portal. However, after the portal has loaded, the map/feature layer/etc. does not appear. I've tried listening to the signals or waiting for the portal & item to finish loading before adding it to my map. However, there are no errors or anything else to debug off of to help me figure this out.

As I stated above, I've essentially followed the "display a map" tutorial along with the "Access Services with OAuth" tutorial. I've only swapped in the correct portal URL and item ID. I've tried basemaps, feature layers (following the correct add via the operationalLayers), waiting for loads, etc etc.

What other methods might I try to debug this? Or is it that even though I have access through my web browser to these items, my OAuth application does not? Let me know if further info is needed.


Note: I'm using Qt 6 and ArcGIS Toolkit 200.


Update: If I explicitly load a FeatureLayer, upon doneLoading I receive "Invalid request Response" error 7003. If I don't explicitly load, it never is actually doneLoading no matter if I'm zoomed into where it should asynchronously call load.

0 Kudos
0 Replies