Why Arcpro Python Script tool takes too long to finish?

127
3
12-05-2021 03:52 PM
LanNguyen1
New Contributor III

Hi All,

I'm now migrating my script tools from ArcMap to ArcPro (2.7.4). I noticed that all the tools run slower than normal.

Some of my tools use the Feature Set as Input to get the temporary polygon digitised by users then doing something with the polygon. Old version of the tool in ArcMap takes 10 seconds to run while new version in ArcPro 2.7.4 takes 5 to 6 minutes (!) to run. 

Has anyone experience the same issue and found the solution? 

Thank you!

Kind regards,

L

Tags (3)
0 Kudos
3 Replies
DanPatterson
MVP Esteemed Contributor

First step is to review this

Troubleshooting Performance Issues in ArcGIS Pro - Esri Community

Pro also requires much better hardware than arcmap does, so run your computer's ability check on this page to rule out anything not so obvious

ArcGIS Pro 2.9 system requirements—ArcGIS Pro | Documentation

don't consider "minimum requirements" as being acceptable either


... sort of retired...
LanNguyen1
New Contributor III

Thank Dan!

I actually run ArcPro on a Windows desktop deployed by IT in Azure as I believe. I had to chance to compare but I will ask them tomorrow in the meeting. We are moving forward, not backward and having a 10s script running in 6m is not easy to tolerant :)

I did think about upgrade them to Py toolbox. However, it the issue is somewhere in the hardware, I dont think pyt will be better.

I hate to move up to creating Addin in .Net because it is a big job...

Kind regards,

L

0 Kudos
DanPatterson
MVP Esteemed Contributor

Make sure you go over the virtualization tips in Kory's link ( Troubleshooting Performance Issues in ArcGIS Pro - Esri Community )

and compare the same test functionality on a local machine with locally stored data.

You want to remove the "cloudy" ish stuff from any comparison


... sort of retired...
0 Kudos