mkl-service package failed to import error when using PyCharm Pro 2021.2.2

916
1
09-18-2021 08:26 PM
GavinPaw
New Contributor

I have been attempting to set up PyCharm for use with Arcpy and ArcGIS Pro using the default environment and whenever I run a script it prints out the following

C:\Program Files\ArcGIS\Pro\bin\Python\envs\arcgispro-py3\lib\site-packages\numpy\__init__.py:143: UserWarning: mkl-service package failed to import, therefore Intel(R) MKL initialization ensuring its correct out-of-the box operation under condition when Gnu OpenMP had already been loaded by Python process is not assured. Please install mkl-service package, see http://github.com/IntelPython/mkl-service
from . import _distributor_init

doesn't seem to matter what the script is. I've ran things ranging from just a print statement alone in a file, to some basic numpy array creation and manipulation and then a mkl.get_version_string() all of which seemed to work correctly outside of the message printing right beforehand

how would I go about fixing the error and if its not fixed what might actually break?

0 Kudos
1 Reply
Subu_Swaminathan_GISP
New Contributor II

@GavinPaw - I get the same error.

One important note is that the error occurs only with PyCharm Professional and not PyCharm Community edition.

0 Kudos