ArcPy - Map Series Occasionally Outputting Elements Erratically

122
0
a month ago
prpanehal
New Contributor

Overview

I completed an automated map series / map making tool utilizing the Python Toolbox. While it generally works fine, it occasionally does not output certain elements, and the inset map / extent indicator fails to render the map series index layer at all. The strange part is if the tool is ran again, it works just fine. It honestly seems to be something during the tool runtime taking too long and timing out. 

Some background:

These maps need to be put out according to different specifications while pulling from different data sources, and the method to handling that involves having multiple ArcGIS Project files set up with those data sources and needs. The user has to select the correct project file based off of some validation rules.

Then the tool runs, it determines the locality based off other parameters, and focuses on that area and other related data and definition queries. The map series index layer is updated each time with the new index grids. It is located in a file geodatabase. The tool then modifies the layers, labels, and etc, then outputs the PDF.

There are five parts to a project file:

  1. Front Page Index Map Layout (Uses Front Page Index Map)
  2. The Map Series Map Layout (Uses Map Series Map and Inset Map)
  3. Cover Page Index Map
  4. The Map Series Map
  5. Inset Map

When the inset map / extent indicator fails to render correctly inside of the Map Series Map Layout, the layer it is reading from renders just fine inside of the Cover Page Index Map Layout inside of the final PDF.

I guess the main question is if others have experienced this behavior, and were they able to resolve it?

0 Kudos
0 Replies