GTFS Network Dataset never uses transit options

222
1
12-08-2021 04:15 AM
ChielvandeCamp
New Contributor

Hi there, I could really use some help with a network dataset that I have built that uses GTFS data. I built the network using Street data of The Netherlands and GTFS data, but when I build a service area or a route, it never uses the transit options. 

I built the network using the GTFS network analyst tools and guide (link) and used transit feed from https://transitfeeds.com/p/ov/814

I think there is something wrong with the settings of the travel attributes. The impedance of my travel mode for bot along and against is set to 'Prohibited', making it logic that it can't use the transit network. 

 

ChielvandeCamp_2-1638965595073.png

Would really appreciate if anybody could help me out finding how to change this to make the network work! 

Thanks!

 

 

 

0 Kudos
1 Reply
MelindaMorang
Esri Regular Contributor

Hi. I can help you with this.

I'm not sure what the "GTFS network analyst tools and guide" is that you mentioned because that link goes to an ArcGIS Online org I don't have permissions to see. However, since your screenshot is ArcGIS Pro, and you have something called LineVariantElements, I am assuming you followed this tutorial or something similar.

The reason your screenshot of the Explore Network pane is showing Prohibited for the impedance in both directions is most likely because you don't have a date and time set. If you flip to the Settings subtab, you can set the date and time, and then the Values grid should update to show the public transit impedance for that date and time.

If you don't set a date and time for your analysis (and also for the Explore Network pane), the transit lines are treated as restricted. The Public Transit evaluator requires a date and time so it can look up the transit schedules and return the correct value for that time of day. So, the first thing for you to check is that you have set a date and time for your Service Area and Route analysis. There are some details in the tutorial I linked to above about how to do this and how to ensure you've selected a valid date and time for your data.

If that doesn't solve the problem, please post again with more details.

0 Kudos