Select to view content in your preferred language

Error in GTFS To Public Transit Data Model Tool

973
2
04-06-2022 06:47 PM
WendyNgan
New Contributor

WendyNgan_0-1649295467167.png

Hello, I received the above error message when I tried to use this tool. I don't think it's an issue with my GTFS data, since a year ago I used this tool last year in v.2.8 when it was called "GTFS To Network Dataset Transit Sources tool" and it worked fine. With the same dataset I still received the same error. I see the stops feature class loaded correctly, but for LineVariantElements nothing shows up, and when I tried to open the tables (CalendarExceptions, Calendars, Lines, LineVariants, Runs, ScheduleElements, Schedules), it says "Failed to open table". How can I resolve it?

Thanks in advance!

UPDATE: This is resolved, turns out it was because I was working on a Network Drive, I changed it to local and everything is running fine 🙂

0 Kudos
2 Replies
MelindaMorang
Esri Regular Contributor

Hello Wendy.

I'm glad you resolved your issue.

Would you remind telling me a bit more about your setup so I can try to fix this problem in case other users run into it? Ideally, the tool should work with data on a network drive.

Here are some questions:

  1. From the error message, it looks like your GTFS data is on a drive called "H:".  Is that your network drive?
  2. Is the file geodatabase where the output is going also on the "H:" drive, or is that somewhere else?
  3. What is your network drive? Is it OneDrive, some other type of share set up by your organization?  I think this is what I really need to know so I can try to mimic the setup and reproduce the problem (and then fix it).

Thank you!

0 Kudos
mcintoshE
New Contributor

I ran into this exact same error, and it turned out to have been caused by the fact that I didn't specify a coordinate system in the feature dataset that I was using as the target.

0 Kudos