Oriented Imagery Web App doesn't support non-english language settings

166
2
Jump to solution
08-01-2021 06:49 AM
Labels (1)
Gaëtan_Lavenu
New Contributor II

Hi,

When you use the Oriented Imagery Web Viewer (https://oi1.img.arcgis.com/app/index.html) with a browser configured with non-english language settings (french for exemple), the app doesn't work (no OI interface displayed, no images displayed, ...). When you change the language settings to English, on the same OIC, the app works as expected.

See the screenshot joined to this post for the error message about missing NLS ressources.

Is there a way to access the source code of this app, to localize it and host it on our own server ?

0 Kudos
1 Solution

Accepted Solutions
RandallRebello
New Contributor III

HI   Gaëtan_Lavenu,

We are looking into internationalization and localization for an upcoming release. However you can solve your issue by specifying the locale in the url. See below for the example.

https://oi1.img.arcgis.com/app/index.html?locale=en

This will load the page using the english locale and work on French OS. 

Randall

View solution in original post

2 Replies
RandallRebello
New Contributor III

HI   Gaëtan_Lavenu,

We are looking into internationalization and localization for an upcoming release. However you can solve your issue by specifying the locale in the url. See below for the example.

https://oi1.img.arcgis.com/app/index.html?locale=en

This will load the page using the english locale and work on French OS. 

Randall

View solution in original post

Gaëtan_Lavenu
New Contributor II

Hi Randall,

Thank you for your answer, using the url parameter "locale=en" works for me. As french distributor, Esri France can help if you need help for french strings translation. Contact me if needed.

Gaëtan Lavenu
Esri France

0 Kudos