Model Builder Updates Edit Version Information

224
2
Jump to solution
05-06-2022 01:38 PM
Labels (3)
ZJK
by
New Contributor III

I have a geodatabase connection set up as an SDE with various versions for editing. For reconciling and posting edits, I use a ModelBuilder script drawn out with the various edit versions included. However, I recently changed the names of one of my editing versions within the SDE. When running the model builder script, I noticed that the version with the updated name seems to be left out of the process. Also, the "Edit Versions" data in the Parameters tab of multiple tools within the ModelBuilder script still lists the old Edit Version name. However, I can't remove the old version name or add in a new one. Is there a way to remove and add this kind of information into the scripts? The below screenshot shows the tool I've been trying to update the data on.

Thanks, 

ZJK

 

ModelBuilderToolParameters.JPG 

1 Solution

Accepted Solutions
Mike_I
by Esri Contributor
Esri Contributor

Hello @ZJK,

Have you tried refreshing the WinonaCo.sde  input? i.e. Now that the versioning has changed, maybe remove the current WinonaCo.sde input and bring in an updated WinonaCo.sde input. I wonder if the model needs that for the versioning inputs to be updated.

Cheers,

Mike

Data Management Specialist, Esri Support Services

View solution in original post

0 Kudos
2 Replies
Mike_I
by Esri Contributor
Esri Contributor

Hello @ZJK,

Have you tried refreshing the WinonaCo.sde  input? i.e. Now that the versioning has changed, maybe remove the current WinonaCo.sde input and bring in an updated WinonaCo.sde input. I wonder if the model needs that for the versioning inputs to be updated.

Cheers,

Mike

Data Management Specialist, Esri Support Services
0 Kudos
ZJK
by
New Contributor III

@Mike_I ,

I didn't find a method to "refresh" the list of Edit Versions. However when I constructed a new model with the same tools, the updated names showed up within the sde.

Thanks, 

ZJK