Vertical datum conversion in ArcGIS Pro not recognizing vertical coordinate system

715
5
05-20-2021 10:17 AM
GeraldGabrisch
New Contributor

I have a GeoTiff surface model and the z values reference EGM96. I would like to use the vertical datum conversion capabilities in ArcGIS Pro 2.7 to convert the GeoTiff to reference the NAVD88 vertical datum.

I see that the *Project Raster* tool includes a checkbox for applying vertical transformations. This checkbox disappears when I select my input raster. After reading the tool documentation.
I understand the vertical option is only available if and only if the data have vertical datum information.

Thinking that the data must lack vertical information read that I can add vertical datum information using the *Define Projection* tool. Trouble is, when I add my surface model to the Define Projection tool the Define Projection tool states that the data have vertical information.  Thinking that there must be something about the GeoTiff that Pro is not recognizing I ran the Define Projection despite the warning on the tool.

After running "Define Projection" the Project Raster tool still removed the vertical option once I added the GeoTiff suggesting the tool is again not seeing the vertical information.

I see this from the tool help:

To perform a vertical transformation, check the optional Vertical parameter on the dialog box. By default, the Vertical parameter is unavailable and is only available when the input and output coordinate systems have a vertical coordinate system (VCS), and the input feature class coordinates have z-values. Also, additional data (coordinate systems data) setup must be installed on the system

 

What is this additional coordinate system data come from and where is it installed? In short, how do I apply a vertical transformation to these data?

0 Kudos
5 Replies
Tim_McGinnes
Occasional Contributor III

The additional coordinate systems are an extra setup executable you have to download from MyEsri and install after ArcGIS.

In order to make the Vertical Transformation checkbox appear, you have to choose the output coordinate system first. In your screenshot it is still blank. Once you choose both an output horizontal and vertical coordinate system, the checkbox should appear - see screenshot.

BojanŠavrič
Esri Contributor

Additional Coordinate System Data install can be downloaded from My Esri download page. It does not require additional license, just access to your organizational My Esri account. This graphic might help you located the install on the side. The thread includes some information on the installs and here is a little bit extra information. I hope this helps.

--------

On the side note... Your shuksan.tif dataset has mixed-up coordinate systems. EGM96 is gravity-related vertical CS based of WGS84. So any EGM96 data should be combined with WGS84 geographic CS. Before you will be able to transform your vertical data, you will need to move your data to WGS 1984 geographic coordinate system using (1) Project Raster tool and (2) Vertical Checkbox unchecked. This step will only change your horizontal coordinates and keep your heights the same. In the following step, you should be able to transform your data from WGS84/EGM96 to NAD 1983 State Plane Washington…/NAVD 1988 with (1) Project Raster tool, (2) Vertical Checkbox checked, and (3) Coordinate System Data installed.

BIA__Office_of_Trust_ServicesD
New Contributor II

Thanks for you help.  Referencing your attached graphic I cannot see a 'Data and Content' link from my organizations download page.

image.png

0 Kudos
BojanŠavrič
Esri Contributor

I am not sure. Do you have more dropdown menus listed under "Core Products" in the main window? If not, I would suggest you to contact your administrator and ask them where you can find ArcGIS Coordinate System Data installs. I hope this help... 

0 Kudos
FrancesBiles1
New Contributor III

Kudos to @BojanŠavrič for pointing out the mixed horizontal and vertical reference systems and the need to install the additional Coordinate System Data file. 

However, BEWARE there are bugs in the ArcGIS Pro Project Raster tool when using it for vertical transformations. These are confirmed ESRI bugs that were identified when going from NAD 1983 (2011) State Plane Alaska 1 FIPS 5001 (Meters)/NAVD88 (Geoid12b) --> ITRF08 geographic coordinates and ITRF08 ellipsoid heights.  The issues go back to at least version 2.4.3 and vary depending on the software version. The issue particular to 2.7 is that the vertical transformation does not occur. The data appears to move correctly in the horizontal but is not being transformed in the vertical. In addition, deleting or retaining the tildes in the transformation strings seems to have no effect (suggesting they are being ignored). As of version 2.8 this bug is still unresolved. [#BUG-000137632].

The bug was only verified for the NAD 1983 (2011)/NAVD88 (Geoid12B) --> ITRF08/ITRF08 case, not when going from EGM96-->NAVD88. I don't know whether the bug persists with different datum transformation combinations, but I would suggest a careful inspection of your output to verify the transformation occurred and the output elevations are what you expect.

For anyone using earlier versions of Pro, a different bug exists in versions 2.4.3 - 2.6.3 [#BUG-000128301, originally submitted 1/31/2020 and never resolved as far as I know]. For the datum case above, going from NAD83(2011)/NAVD88(Geoid12B)-->ITRF08/ITRF08, if you accept the auto-populated, default geographic transformation method (~NAD_1983_2011_To_NAVD88_Alaska_GEOID12B_Height + ~ITRF_2008_To_NAD_1983_2011), your output will be moved horizontally in the wrong direction (the opposite direction it should move) unless you manually delete the tilde in front of the 2nd half of the transformation string (the horizontal portion).  Manually deleting this tilde, using an ArcPro version from 2.4.3 - 2.6.3, is the only way I've found to perform a successful horizontal + vertical datum conversion for a raster with ESRI geoprocessing tools.

If you do not delete the 2nd tilde, your output will be moved horizontally in the wrong direction if your input is a geotiff.  If your input is a file geodatabase raster and you do not delete the 2nd tilde, the horizontal conversion looks correct, but heights are slightly lower than if you delete the tilde.  Complicated, I know...

0 Kudos