Problem with background audio in sidecar

205
2
Jump to solution
11-21-2021 07:46 AM
EricBenjaminson
New Contributor

Hello! I'm  a fairly new user of StoryMaps and am really enjoying this product! One question please: I have put a short audio clip in the background of one of my sidecars -- it's an MP3 file. I was able to insert it in the sidecar, but when I navigate to that sidecar, the clip doesn't automatically start playing. Thanks for the help!

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
OwenGeo
Esri Frequent Contributor

Hi @EricBenjaminson -- Welcome to the StoryMaps community! We're glad you're enjoying your experience so far.

There might be a few things going on. First, please know that background audio will only start playing when you're previewing your story or when you're viewing the published story. It doesn't play in the story builder so it doesn't get in your way while you're still working on your story.

The second thing is that there are specific behaviors that web browsers enforce related to automatically playing audio (or video with audio). Browsers have implemented these mostly so that when you go to websites you don't start hearing annoying ads without warning, but the limitations apply to all websites including StoryMaps. Basically, web browsers require people to explicitly opt-in to hearing audio when visiting a new web page.

So when a reader gets to a slide that has background audio, there's a button at the top of the media panel that they need to press to enable audio. Once they click this the audio will begin. Here's an example from this great story about the sounds of the Montana wilderness.

Screen Shot 2021-11-22 at 7.59.02 AM.jpg

Let me know if this answers your questions about background audio.

Owen Evans
Lead Product Engineer | StoryMaps

View solution in original post

2 Replies
OwenGeo
Esri Frequent Contributor

Hi @EricBenjaminson -- Welcome to the StoryMaps community! We're glad you're enjoying your experience so far.

There might be a few things going on. First, please know that background audio will only start playing when you're previewing your story or when you're viewing the published story. It doesn't play in the story builder so it doesn't get in your way while you're still working on your story.

The second thing is that there are specific behaviors that web browsers enforce related to automatically playing audio (or video with audio). Browsers have implemented these mostly so that when you go to websites you don't start hearing annoying ads without warning, but the limitations apply to all websites including StoryMaps. Basically, web browsers require people to explicitly opt-in to hearing audio when visiting a new web page.

So when a reader gets to a slide that has background audio, there's a button at the top of the media panel that they need to press to enable audio. Once they click this the audio will begin. Here's an example from this great story about the sounds of the Montana wilderness.

Screen Shot 2021-11-22 at 7.59.02 AM.jpg

Let me know if this answers your questions about background audio.

Owen Evans
Lead Product Engineer | StoryMaps

View solution in original post

EricBenjaminson
New Contributor

Hi Owen, Thanks very much! It works perfectly when I switched to Preview mode, just as you said. I appreciate it!  Eric