Workforce - Survey123 Integration: Inspect an asset without creating a new point

394
5
07-21-2021 08:37 AM
PanGIS
by
Regular Contributor

Hi!

 

I have a Survey created in Connect that collects info about water meter conditions in a property.

 

- Feature Class: point, with a number of static info like address, account number, Water meter number.....

- Related table (via GUID) 1:M -  Account number and water meter number are copied from the main feature via Survey, date of inspection, and conditions....

 

On the Survey inbox works like a charm.

 

On Workforce:

The problem is that, whenever I create a new assignment, and I open it on Workforce mobile, survey123 opens, and I collect info. when i check my data , I realize that I've created a new point completely unrelated from the existing one.

The only info I pass from Work force to Survey123 is the location name, (but to be honest I don't understand exactly how the "Pass info" should be used in a proper way.)

 

I don't need to modify anything in the feature point, just the inspection table.

Am I doing something wrong (any documentation?)

Or there is still no way to integrate properly the two apps?

 

Thank you for any feedback! :smiling_face_with_smiling_eyes:

0 Kudos
5 Replies
IanGallo
New Contributor III

URL Parameters work quite well. Create the URL and add a hyperlink to the popup in the worker map. You can pass coordinates using this as well. Make sure you set the number of decimal places desired for you x,y in the "configure attributes" pane of the configure pop-up menu for the layer that you are populating your survey with. 

Integrate with other apps—ArcGIS Survey123 | Documentation

PanGIS
by
Regular Contributor

Hi @IanGallo thank you for your input.

 

I am still confused, so I describe what I did.

 

According to your suggestion:

I created the URL and I configured the pop up for the feature layer as:

https://survey123.arcgis.com/share/<itemID>?mode=edit&globalId={GlobalID}  ---> it works when I click on the feature.

I also tried with 

https://survey123.arcgis.app/?itemID=<itemID>&globalId={GlobalID}  --> and the app doesn't open to the right survey.

-------

The issue with the above method is that the survey is linked to the feature and not the assignment.

I tried to modify the URL Template in the Assignment Integrations  table to:

https://survey123.arcgis.app/?itemID=<itemID>&globalId={GlobalID}   (actually insted of {GlobalId} I tried to find a way to link to the feature's GlobalId but nothing worked. like nameOfTheFeature.GlobalID)

 

What I would like to get is:

Click on the assignment.

Start the assignment

Click on  Survey at assignment and get the form opened  

 

Thanks!

0 Kudos
IanGallo
New Contributor III

Check out this link - Not sure how you want your data to be structured.

Solved: Survey123 Integration - Populate Custom Attribute ... - Esri Community

BrandonGuo
New Contributor III

Similar issue here, when open FieldMaps from Workforce, it auto opens the create new point window, instead of the inspect the current asset. The Workforce integration is not documented clearly makes it really confusing to use. 

0 Kudos
PanGIS
by
Regular Contributor

Hi @BrandonGuo I found a solution here: Re: New Inspection Project - Esri Community

Craig Gillgrass gave me a way to get what I wanted.

It works.

0 Kudos