How to determine the version of a Widget being used?

171
4
Jump to solution
08-15-2022 11:42 AM
Labels (1)
FayGlunt
New Contributor III

How can we determine what version of the Filter Widget that we are using in our Web App Builder?  We have determined we are using 2.25 of Web App Builder using the developer tools and requesting the wabversion.  But, we do not know how to see the version of the widget.  We are experiencing the sort issue in BUG-000099321, but the bug documentation says that it was fixed in version 4.4.  Is there a way we can see what version we are using?

https://community.esri.com/t5/arcgis-online-questions/sorting-dropdown-list-alphabetically-in-filter...

https://support.esri.com/bugs/nimbus/QlVHLTAwMDA5OTMyMQ==

 

2 Solutions

Accepted Solutions
SSchott_CLAU
New Contributor II

@FayGlunt , you can view the .json of the web app in ArcGIS Online Assistant. Use this link to sign into your Portal https://ago-assistant.esri.com/. Select "View an item's json" in the dropdown, then search for the app you are looking. In the json you will see the version of the widget you are using.

SSchott_Corelogic_1-1660608982434.png

eg. This is the version of the search widget my app is using, as seen in the AGO-assistant tool.

SSchott_Corelogic_0-1660608753080.png

 

View solution in original post

SSchott_CLAU
New Contributor II

@FayGlunt , if you are using the Out of the Box version of Web Appbuilder and the web app was not created in an older version of ArcGIS Enterprise (before upgrading), I'm not sure you may need to ask Esri support.

If the web app was created before an upgrade, you need to re-add the widget to the web app and reconfigure the widget, then save. This will enforce the web app to use the newer version of the widget.

View solution in original post

4 Replies
SSchott_CLAU
New Contributor II

@FayGlunt , you can view the .json of the web app in ArcGIS Online Assistant. Use this link to sign into your Portal https://ago-assistant.esri.com/. Select "View an item's json" in the dropdown, then search for the app you are looking. In the json you will see the version of the widget you are using.

SSchott_Corelogic_1-1660608982434.png

eg. This is the version of the search widget my app is using, as seen in the AGO-assistant tool.

SSchott_Corelogic_0-1660608753080.png

 

FayGlunt
New Contributor III

Thank you soooo much, SSchott_Corelogic

This is exactly what we needed!!  You Rock!!

I can see we are still using version 2.25 of that widget.  Do you know by chance, how we get the the latest greatest version?

SSchott_CLAU
New Contributor II

@FayGlunt , if you are using the Out of the Box version of Web Appbuilder and the web app was not created in an older version of ArcGIS Enterprise (before upgrading), I'm not sure you may need to ask Esri support.

If the web app was created before an upgrade, you need to re-add the widget to the web app and reconfigure the widget, then save. This will enforce the web app to use the newer version of the widget.

FayGlunt
New Contributor III

Thank you, @SSchott_CLAU !!!!  Appreciate it.

0 Kudos