HELP - Web Map in Web AppBuilder isn't reflecting web map

86
2
11-16-2022 09:38 AM
LydiaWerner_MAC
New Contributor II

I have a web app I built in Web AppBuilder that is running a web map that I created in Map Viewer. In Map Viewer, I have the Feature Display Order set to order by a particular field (this one is a date/time attribute) and set up to sort the features with the most recent dates on top. 

My Dashboard with this web map correctly reflects this setting, in addition to my web map in Map Viewer. 

However, the map in the Web AppBuilder does not and instead displays features with the older dates on top. This seems to be a bug with Web AppBuilder; if not, I have tried many, many, many "fixes" to no avail. I even tried creating a new Web App, and this did not work.

0 Kudos
2 Replies
KenBuja
MVP Esteemed Contributor

Remember that Web AppBuilder was built with the JavaScript 3.x API, which doesn't have some of the capabilities of the newer 4.x API that the Map Viewer uses. If you open your map in Map Viewer Classic (also built in 3.x), you'll see those deficiencies.

If you need those capabilities, you would have to create an app in Experience Builder, which is built with the JavaScript 4.x API (as is the Dashboard).

0 Kudos
LydiaWerner_MAC
New Contributor II

I have seen this response often. If I use Map Viewer Classic, there is map symbology functionality that's only an option through Map Viewer, not Classic, which to me is a step back. Thanks for the response.

0 Kudos