Vector Tile Style Editor and Community Maps

435
3
Jump to solution
02-08-2021 01:19 PM
Alyssia
Occasional Contributor

Hello, 

My city has been an active contributor to the Community Maps program which has been great for us so far. However, I am having trouble understanding why I cannot access the vector tile layers which are updated through the community maps program in the Vector Tile Style Editor. When I go to select the basemap I would like to start with in the editor, none of the community maps layers appear except for one in dark mode that I don't need.  These are the layers I would like to be able to adjust the style on (mostly remove labels I don't need and adjust some colors): https://www.arcgis.com/home/group.html?id=5ce5f87eb0824fed889e57795f7cab95&rmedium=esriurl_com_9_e&r...

 

Thanks for any help!

0 Kudos
1 Solution

Accepted Solutions
ssarakaitis
New Contributor II

Hi Alyssia, so sorry for such a long delay!

It's true we only use some layers (Roads/admin lines) for certain basemaps, but all other layers (Buildings, waterbodies, etc) are used in all basemap styles.  Of course some designs like the Hybrid does not use many styles since it's meant to be a mixture of Imagery and POI/Roads.  We have a few options like this group of Vector Styles which do use all Community (Roads/Admin Lines) here.  https://www.arcgis.com/home/group.html?id=5ce5f87eb0824fed889e57795f7cab95#overview

Please reach out at communitymaps@esri.com if you have further questions!

View solution in original post

3 Replies
jcarlson
MVP Regular Contributor

Are there specific layers in the basemaps you're trying to access but aren't seeing? And is the issue that the layer doesn't appear the basemap at all, or that it's simply not in the Style Editor that pops up? I've tested re-styling some of the Esri basemaps and haven't seen any issues with the Community Maps content showing up.

- Josh Carlson
Kendall County GIS
0 Kudos
Alyssia
Occasional Contributor

Thanks for your reply. Here is the full story. 

I was using a hybrid reference layer that I had edited a bit using the Style Editor and saved to my account. I noticed a few weeks ago that the newest road updates I had submitted to the Community Maps program were not showing up. I contacted the Esri Community Maps staff about the issue and I learned that only the tile layers shown at this link will have the Community Maps contributions updated: https://www.arcgis.com/home/group.html?id=5ce5f87eb0824fed889e57795f7cab95&rmedium=esriurl_com_9_e&r...

I am specifically wanting to adjust this layer to my liking but can't find it in the list of styles to edit: https://www.arcgis.com/home/item.html?id=b0f00f41a0ed4cb695760001d5be5c63

I get stuck on the following screen and no matter which tab I select at the top, I can't find this specific layer. The only community maps layer I could select to edit was a dark mode one that I don't need. 

Alyssia_1-1612820986003.png

Maybe I am doing something wrong or missing something?

 

 

0 Kudos
ssarakaitis
New Contributor II

Hi Alyssia, so sorry for such a long delay!

It's true we only use some layers (Roads/admin lines) for certain basemaps, but all other layers (Buildings, waterbodies, etc) are used in all basemap styles.  Of course some designs like the Hybrid does not use many styles since it's meant to be a mixture of Imagery and POI/Roads.  We have a few options like this group of Vector Styles which do use all Community (Roads/Admin Lines) here.  https://www.arcgis.com/home/group.html?id=5ce5f87eb0824fed889e57795f7cab95#overview

Please reach out at communitymaps@esri.com if you have further questions!

View solution in original post