Modify Associations layer name

326
7
Jump to solution
02-13-2024 04:24 PM
joecastellana
New Contributor II

Hello all,

I am having difficulty with the modify associations view. In the junction-junction section of the connectivity tab, I am not able to change the display name of connected records. So I cant tell which feature each row relates to. And also when I right click, the "select" option doesnt actually select and there is no option to "flash". 

Using arcgis pro v2.9.5 and UN v5. Any advice? tia

joecastellana_0-1707869810379.png

 

0 Kudos
2 Solutions

Accepted Solutions
MikeMillerGIS
Esri Frequent Contributor

You can adjust the display by changing the display field:

MikeMillerGIS_0-1707906319771.png

 

On 3.2, there is a flash on the right click and select does work.  Maybe it was fixed in 2.9.9

MikeMillerGIS_1-1707906347123.png

 

View solution in original post

0 Kudos
MikeMillerGIS
Esri Frequent Contributor

Listing the Junction Object tables with def queries does cause issues with the association tools.  We do not split them up with def queries and just leave them as one table.  They are adding subtype group tables to 3.3 to resolve this issue, but for now, one table in the map is the best option.

View solution in original post

7 Replies
MikeMillerGIS
Esri Frequent Contributor

You can adjust the display by changing the display field:

MikeMillerGIS_0-1707906319771.png

 

On 3.2, there is a flash on the right click and select does work.  Maybe it was fixed in 2.9.9

MikeMillerGIS_1-1707906347123.png

 

0 Kudos
joecastellana
New Contributor II

Thanks Mike, I can see thats how it should work but in many cases thats not how the app is working unfortunately. Im not sure if this is a common/known issue or some other blocker is present.

You can see in the two snips the modify associations display is different despite the same settings.

atts.pngmod assoc.png

0 Kudos
MikeMillerGIS
Esri Frequent Contributor
Have you repeated the later in the map? I would suggest logging a tech support incident.

0 Kudos
joecastellana
New Contributor II

What do you mean repeat in the map Mike?

0 Kudos
MikeMillerGIS
Esri Frequent Contributor

Do you have a layer in the map pointing to the same target Service Layer more than once.  Maybe it is repeated with a def query?  Subtype Group Layers count as one layer

0 Kudos
joecastellana
New Contributor II

Thanks Mike. Yes I do have multiple layers managed w/ definition query including the Electric Junction Object table from the above screen shots. Is there possibly something Ive set up incorrectly, or some best practice I should follow to allow Modify Associations tool to work with this config? 

0 Kudos
MikeMillerGIS
Esri Frequent Contributor

Listing the Junction Object tables with def queries does cause issues with the association tools.  We do not split them up with def queries and just leave them as one table.  They are adding subtype group tables to 3.3 to resolve this issue, but for now, one table in the map is the best option.