Cannot view asset group in experience builder

311
4
Jump to solution
02-14-2024 09:51 PM
NadiaAlami
New Contributor III

Hi and good day everyone, 

We try to use experience builder for our utility network, however after we add the web map, we cant see the asset group in select data .For example in water device we have several asset group like fire hydrant dam service connection and many more but we just see as figure below.

NadiaAlami_0-1707975321300.png
we follow a tutorial in the youtube where supposed when we select the data, the asset group of the data is there like image below.

NadiaAlami_2-1707976213698.png

 

what should we do? is there any setting in web map that we need to configure? Attached below web map that we use in the experience builder.

NadiaAlami_1-1707976145384.png


Any suggestion? thank you 


 

0 Kudos
1 Solution

Accepted Solutions
RobertKrisher
Esri Regular Contributor

@NadiaAlami thank you for sharing this link, it was able to confirm my hypothesis (about the solution and that it was from a business partner). The web map that is being used has had normal group layers added to it with multiple copies of the device and layers added to it with definition queries applied. They describe this step in their previous video that shows you how to create the web map (https://youtu.be/rgUG5WzAeQ4?si=wWrmcd1ITlezo5JX&t=80).

What you're seeing isn't subtype group layers or experience builder showing asset groups, it's just a collection of layers under a group layer with definition queries applied. They chose to do this using regular group layers, instead of subtype group layers, because the experience builder does not currently support subtype group layers, and they wanted to see their results separated out by asset group.

Manually separating out your layers using definition queries is typically not recommended because of the performance cost (you have to query/render the same layer multiple times) but because it is only being done a handful of times this should still perform reasonably well.

View solution in original post

0 Kudos
4 Replies
RobertKrisher
Esri Regular Contributor

@NadiaAlami can you share a link to the YouTube video you are watching? I suspect one of two different possibilities for this but would like to see the tutorial you're trying to follow before recommending a course of action.

0 Kudos
NadiaAlami
New Contributor III

Hi, mr RobertKrisher,here the link..

https://youtu.be/bWstg1IMa1M?si=6063o19Jk2ZWU_Br
 we try to follow this step actually..
thank you ..

0 Kudos
RobertKrisher
Esri Regular Contributor

@NadiaAlami thank you for sharing this link, it was able to confirm my hypothesis (about the solution and that it was from a business partner). The web map that is being used has had normal group layers added to it with multiple copies of the device and layers added to it with definition queries applied. They describe this step in their previous video that shows you how to create the web map (https://youtu.be/rgUG5WzAeQ4?si=wWrmcd1ITlezo5JX&t=80).

What you're seeing isn't subtype group layers or experience builder showing asset groups, it's just a collection of layers under a group layer with definition queries applied. They chose to do this using regular group layers, instead of subtype group layers, because the experience builder does not currently support subtype group layers, and they wanted to see their results separated out by asset group.

Manually separating out your layers using definition queries is typically not recommended because of the performance cost (you have to query/render the same layer multiple times) but because it is only being done a handful of times this should still perform reasonably well.

0 Kudos
NadiaAlami
New Contributor III

Hi Mr RobertKrisher,
Thank you so much for the explanation. Now i understand .

0 Kudos