Attribute rule evaluation error 999999

65
2
Thursday
xyz_AL
by
New Contributor III

Hi all,

here is the workflow I've followed:

  1. create the Sewer Asset Package from ETL
  2. create the Utility Network from Asset Package
  3. activate the Attribute Rule "StructureJunction - Create Manhole Channel batch"
  4. run Evaluate Rules
  5. activate the Attribute Rule "Line - Snap to Manhole batch" (and disable the previous one)
  6. run Evaluate Rules

I've tested the same workflow with the same data in two different environments:

  1. ArcGIS Pro 2.9.5 - UN vers. 5
    • first rule OK
    • second rule ERROR 999999: Something unexpected caused the tool to fail. Contact Esri Technical Support (http://esriurl.com/support) to Report a Bug, and refer to the error help for potential solutions or workarounds.
  2. ArcGIS Pro 3.0 - UN vers. 6 
    • both rules OK

Unfortunately the job must be done using 2.9.5.

Any idea?? Is it a bug?

0 Kudos
2 Replies
MikeMillerGIS
Esri Frequent Contributor

I am not sure what is causing the issue, but if those are the batch rules, they only need to be run once. during data conversion.  

0 Kudos
xyz_AL
by
New Contributor III

Actually, the first time I've activated both the batch rules and the result of the evaluation was the 999999 error.

So then I've tryed to evaluate the two rules separately in order to better understand where the error occurs and I've discovered that the error was during the evaluation of the Pipe Connection creation and snapping rule.

0 Kudos