Webhook data not displaying on Google Sheets in rural area

141
1
Jump to solution
09-17-2021 12:50 PM
JohnnyHarley232
New Contributor III

I have a client that is using my Survey123 form to inspect data in a remote area of Arizona. The Survey has a web hook to populate some very redundant fields in a Google Sheets file. The permissions for the sheet and survey are public. I have verified and tested that the data being populated from Survey123 into Google sheets is displaying on my phone and another persons phone (in the city) but not my client. Since data is being processing through ESRI servers and then talking with Integromat and then to Google Sheets, do you think the issue is that my client has poor reception? He can receive emails and submit data through 123. 

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
ZacharySutherby
Esri Regular Contributor

Hello @JohnnyHarley232

Is the webhook configured with the survey or with the feature service? If the webhook is configured with the survey, Survey123 will submit a request to the Integromat payload URL right after the applyEdits request which goes to your ArcGIS organization with the same information. If you are seeing data in your feature service but the webhook isn't triggering there may be something going on with the request to the Integromat payload URL. 

In Integromat you can check the run history of the webhook, are there webhook triggers at the time your client is submitting data or are the only webhook triggers from your and your colleagues testing? 

Thank you, 

Zach

Thank you,
Zach

View solution in original post

0 Kudos
1 Reply
ZacharySutherby
Esri Regular Contributor

Hello @JohnnyHarley232

Is the webhook configured with the survey or with the feature service? If the webhook is configured with the survey, Survey123 will submit a request to the Integromat payload URL right after the applyEdits request which goes to your ArcGIS organization with the same information. If you are seeing data in your feature service but the webhook isn't triggering there may be something going on with the request to the Integromat payload URL. 

In Integromat you can check the run history of the webhook, are there webhook triggers at the time your client is submitting data or are the only webhook triggers from your and your colleagues testing? 

Thank you, 

Zach

Thank you,
Zach

View solution in original post

0 Kudos