Suvey123 3.13 Recent Update issue

175
6
3 weeks ago
vijaybadugu
Occasional Contributor

I am getting 401 Un authorized error when i try to republish the Survey again. I am using ArcGIS Enterprise 10.9 with IWA Authentication .

0 Kudos
6 Replies
Philip-Wilson
Esri Frequent Contributor

Hi @vijaybadugu,

Can you collect the diagnostic logs when you attempt to re-publish, so we can see the full error information?

Regards,

Phil.

0 Kudos
vijaybadugu
Occasional Contributor

Survey item url with “host authentication required “

Full item url {

401 unauthorized 

}

anyways I will share full info tomorrow 

0 Kudos
vijaybadugu
Occasional Contributor

<15>1 2021-09-28T12:58:43Z <System Name> ArcGISSurvey123Connect 3296 - [AppStudio@11205 category="qml" function="publish" filename="PublishSurvey.qml" line="90"] qml: Publishing to folder: Survey-Wood Lands Pre Operations CheckList
<15>1 2021-09-28T12:58:43Z <System Name> ArcGISSurvey123Connect 3296 - [AppStudio@11205 category="qml" function="log" filename="PublishOptions.qml" line="85"] qml: Publish options -
<15>1 2021-09-28T12:58:43Z <System Name> ArcGISSurvey123Connect 3296 - [AppStudio@11205 category="qml" function="log" filename="PublishOptions.qml" line="86"] qml: deleteFolder: false
<15>1 2021-09-28T12:58:43Z <System Name> ArcGISSurvey123Connect 3296 - [AppStudio@11205 category="qml" function="log" filename="PublishOptions.qml" line="87"] qml: createFeatureService: false
<15>1 2021-09-28T12:58:43Z <System Name> ArcGISSurvey123Connect 3296 - [AppStudio@11205 category="qml" function="log" filename="PublishOptions.qml" line="88"] qml: deleteFeatureService: false
<15>1 2021-09-28T12:58:43Z <System Name> ArcGISSurvey123Connect 3296 - [AppStudio@11205 category="qml" function="log" filename="PublishOptions.qml" line="89"] qml: formPackageOnly: true
<15>1 2021-09-28T12:58:43Z <System Name> ArcGISSurvey123Connect 3296 - [AppStudio@11205 category="qml" function="log" filename="PublishOptions.qml" line="90"] qml: enableEditorTracking: true
<15>1 2021-09-28T12:58:43Z <System Name>ArcGISSurvey123Connect 3296 - [AppStudio@11205 category="qml" function="log" filename="PublishOptions.qml" line="91"] qml: enableExtract: true
<15>1 2021-09-28T12:58:43Z <System Name>ArcGISSurvey123Connect 3296 - [AppStudio@11205 category="qml" function="log" filename="PublishOptions.qml" line="92"] qml: enableSync: false
<15>1 2021-09-28T12:58:43Z <System Name>ArcGISSurvey123Connect 3296 - [AppStudio@11205 category="qml" function="log" filename="PublishOptions.qml" line="93"] qml: addGlobalId: true
<15>1 2021-09-28T12:58:43Z <System Name>ArcGISSurvey123Connect 3296 - [AppStudio@11205 category="qml" function="log" filename="PublishOptions.qml" line="94"] qml: globalIdRelationships: false
<15>1 2021-09-28T12:58:43Z <System Name>ArcGISSurvey123Connect 3296 - [AppStudio@11205 category="qml" function="log" filename="PublishOptions.qml" line="95"] qml: createDomains: true
<15>1 2021-09-28T12:58:43Z <System Name>ArcGISSurvey123Connect 3296 - [AppStudio@11205 category="qml" function="log" filename="PublishOptions.qml" line="96"] qml: forceNullable: true
<15>1 2021-09-28T12:58:43Z <System Name>ArcGISSurvey123Connect 3296 - [AppStudio@11205 category="qml" function="log" filename="PublishOptions.qml" line="97"] qml: webFormTransform: true
<15>1 2021-09-28T12:58:43Z <System Name>ArcGISSurvey123Connect 3296 - [AppStudio@11205 category="qml" function="log" filename="PublishOptions.qml" line="98"] qml: addWebMap: true
<15>1 2021-09-28T12:58:43Z <System Name>ArcGISSurvey123Connect 3296 - [AppStudio@11205 category="qml" function="log" filename="PublishOptions.qml" line="99"] qml: capabilities: Query,Editing,Create,Update,Delete,Extract
<15>1 2021-09-28T12:58:43Z <System Name>ArcGISSurvey123Connect 3296 - [AppStudio@11205 category="qml" function="log" filename="PublishOptions.qml" line="100"] qml: updateCapabilities: true
<15>1 2021-09-28T12:58:43Z <System Name>ArcGISSurvey123Connect 3296 - [AppStudio@11205 category="qml" function="log" filename="PublishOptions.qml" line="101"] qml: includeDatabase: false
<15>1 2021-09-28T12:58:43Z <System Name>ArcGISSurvey123Connect 3296 - [AppStudio@11205 category="qml" function="start" filename="ActionStatusDialog.qml" line="132"] qml: Opening action dialog
<15>1 2021-09-28T12:58:43Z <System Name>ArcGISSurvey123Connect 3296 - [AppStudio@11205 category="PublishSurvey" function="requestFormInfo" filename="PublishSurvey.qml" line="602"] PublishSurvey: Requesting form info for: <item id>
<10>1 2021-09-28T12:58:43Z <System Name>ArcGISSurvey123Connect 3296 - [AppStudio@11205 category="PortalRequest" function="onErrorTextChanged" filename="PortalRequest.qml" line="98"] PortalRequest: portalRequest: https://<domain name >/arcgisportal/sharing/rest/content/items/<item id> error: Host requires authentication
<10>1 2021-09-28T12:58:43Z <System Name>ArcGISSurvey123Connect 3296 - [AppStudio@11205 category="PortalRequest" function="onReadyStateChanged" filename="PortalRequest.qml" line="84"] PortalRequest: PortalRequest status: 401 401 Unauthorized
<10>1 2021-09-28T12:58:43Z <System Name>ArcGISSurvey123Connect 3296 - [AppStudio@11205 category="PortalRequest" function="onFailed" filename="PortalRequest.qml" line="104"] PortalRequest: PortalRequest failed url: https://<domain name >/arcgisportal/sharing/rest/content/items/<item id> error: {
"code": 401,
"message": "401 Unauthorized"
}
<15>1 2021-09-28T12:58:43Z <System Name> ArcGISSurvey123Connect 3296 - [AppStudio@11205 category="qml" function="finished" filename="ActionStatusDialog.qml" line="143"] qml: Actions completed
<15>1 2021-09-28T12:58:45Z <System Name > ArcGISSurvey123Connect 3296 - [AppStudio@11205 category="Portal" function="onStateChanged" filename="Portal.qml" line="404"] Portal: Application state changed: 2

0 Kudos
vijaybadugu
Occasional Contributor

It is happening with all surveys in dev and Production environments

0 Kudos
Philip-Wilson
Esri Frequent Contributor

Hi @vijaybadugu,

Have you logged this issue with Esri Support yet, I think this will be best avenue to resolve this issue quickly as it involves Enterprise and authentication issues that are hard to resolve via Esri Community. Working with a tech support analyst on this issue will be the best way forward.

Regards,

Phil.

0 Kudos
vijaybadugu
Occasional Contributor

I installed 3.12 Survey123 Connect back. It worked and am able to publish the surveys

0 Kudos