Survey123 using an existing feature layer

195
3
Jump to solution
10-18-2021 03:49 AM
SectoAdmin
New Contributor

Hey All,

I have received a feature layer from a local government and a survey template that must be used. I am trying to create a survey and use the feature layer but it comes up with this error.

SectoAdmin_0-1634553902892.png

 

Should I add the fields into the feature service or should I look at down sizing the survey which is not really an option.

Go raibh mile maith agat

0 Kudos
1 Solution

Accepted Solutions
DeonLengton
Esri Contributor

Hi

Personally I would do the following:

1) Create a new survey based on the Feature Layer provided 

2) Publish the new survey at least once then remove the submission url - do this BEFORE you make changes to the survey

3) After publishing and removing the submission url, add the additional 16 fields into the survey by mapping existing fields and adding the new ones that isnt in the feature layer

4) Publish the survey again - it should ask if you want to add the new fields to the Feature Layer 

View solution in original post

3 Replies
DeonLengton
Esri Contributor

Hi

Personally I would do the following:

1) Create a new survey based on the Feature Layer provided 

2) Publish the new survey at least once then remove the submission url - do this BEFORE you make changes to the survey

3) After publishing and removing the submission url, add the additional 16 fields into the survey by mapping existing fields and adding the new ones that isnt in the feature layer

4) Publish the survey again - it should ask if you want to add the new fields to the Feature Layer 

View solution in original post

SectoAdmin
New Contributor

deon, that worked a treat, thank you so much

0 Kudos
DeonLengton
Esri Contributor

Glad to hear! Well done

0 Kudos