Select to view content in your preferred language

Survey123 Pulldata() not working in browser

236
3
Jump to solution
06-17-2024 03:05 PM
KyleBurford
New Contributor II

This is working fine in the S123 field app, but when I try it in the browser I get the following error message:

instance "total_revenue_se2" does not exist in model

total_revenue_se2 is a csv that is included in a pulldata() query:

pulldata('@javascript', 'scripts.js', 'get_total_revenue', pulldata('total_revenue_se2', ‘value’, ‘mgmt’, ${scenario_management_select}), ${planting_size_select})

"value" is simply a field of values that is then plugged into a function ('get_total_revenue') which outputs a table of calculated values.

Any idea why this is not working in the browser?

 

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
DougBrowning
MVP Esteemed Contributor

Typically you cannot nest any function in a pulldata.  This has come up a number of times and the fix is to move the nested pulldata to its own field then use that field in the call.  Give that a shot.

View solution in original post

0 Kudos
3 Replies
DougBrowning
MVP Esteemed Contributor

Typically you cannot nest any function in a pulldata.  This has come up a number of times and the fix is to move the nested pulldata to its own field then use that field in the call.  Give that a shot.

0 Kudos
KyleBurford
New Contributor II

Thank you. I guess I didn't word my search properly. Is the nesting issue only a browser issue?

0 Kudos
DougBrowning
MVP Esteemed Contributor

I think that is normally where it breaks yes.

0 Kudos