Survey123 Integration with FieldMaps, after third submission S123 app screen is black (andoird)

300
3
Jump to solution
06-28-2022 02:48 PM
MeganEngel
Occasional Contributor

I am using a workflow, tested an works on iOS devices but not Android devices.  I will describe the workflow then the error i am encountering with Android devices.

Workflow:

  1. Use FieldMaps to Launch a New S123 form in the field app, using a typical hyperlink format.
  2. Certain parameters are pre-populated from the FM Feature Service I am launching S123 from (plant id, species, common name).
  3. User completes form, mashes send, then is taken back to field maps to continue on with the next form.

Issue (on android only):

  1. User is able to submit 2 forms. When they try to launch S123 a third time, S123 opens into a black screen.
  2. The only way to do the workflow (as designed) is to close everything.

I have had the user confirm both the application versions and software versions, and they are up to date.

This issue is only happening on Android devices; iOS works as designed. Closing an re-opening works, however the client needs to record and document over 700 individual trees, and it is unrealistic to ask them to close everything after every second record is submitted.

Has anyone else encountered this issue, and what was done to fix it?

1 Solution

Accepted Solutions
MeganEngel
Occasional Contributor

By removing the callback portion of the URL, the user was able to successfully submit 5 surveys in a row, each launched from Field Maps.

However, this is a bug that should be resolved with the future builds of the Android applications.

View solution in original post

0 Kudos
3 Replies
DougBrowning
MVP Notable Contributor

So you are using a callback URL right?  Do you notice that when you open 123 back up (without a URL launch) you will see it flicker for a second and complete sending the form?  I have seen this happen where it is not fully done sending the form before it jumps back to Field Maps.  Then it is in a stuck state.  Then when you open a second, and then a third you now have 3 open in the background.  At that point the app prob runs out of memory and gets wonky.

I just added a callback to my projects this year but have not had any reports of this happening.  We are mostly iOS but we are running some Androids.  Some of the Androids are old and slow too (Active 2).

I wonder if this person has a old tablet, have a ton of apps open, have a ton of apps installed, or are really low on space.  

Hope the helps a bit.  Post what you find.  thanks

0 Kudos
MeganEngel
Occasional Contributor

I am using the callback URL, but the user has indicated that when they complete the form they are not called back to the application.  I wonder if it is getting stuck there somewhere.  I am going to try removing the callback portion of the URL and see if this black screen (after 2 submissions) persists.

 

Their tablet is brand new, and the only applications they have open are FM, S123, and Trimble Mobile Manager.

MeganEngel
Occasional Contributor

By removing the callback portion of the URL, the user was able to successfully submit 5 surveys in a row, each launched from Field Maps.

However, this is a bug that should be resolved with the future builds of the Android applications.

0 Kudos